summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaszlo Gombos2024-03-03 22:51:34 -0500
committerLaszlo Gombos2024-03-03 22:51:34 -0500
commit2199bc77bce33691a77518a45eece8da00af71f7 (patch)
treebf9637f31dc406fdc9583518a1a1c3b333b55ac9
parente6b593081b4eb82cb374e26ec1e26a7d2040f6ce (diff)
downloadaur-2199bc77bce33691a77518a45eece8da00af71f7.tar.gz
upgpkg: 060.r6794.4980bad-13: https://github.com/dracutdevs/dracut/pull/2549
-rw-r--r--.SRCINFO6
-rw-r--r--Dockerfile5
-rw-r--r--PKGBUILD5
3 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bde8675ab5d..9882a7b8bef4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dracut-git
pkgdesc = An event driven initramfs infrastructure
pkgver = 060.r6794.4980bad
- pkgrel = 12
+ pkgrel = 13
url = https://github.com/dracutdevs/dracut
arch = x86_64
license = GPL-2.0-or-later
@@ -42,6 +42,7 @@ pkgbase = dracut-git
depends = systemd
depends = util-linux
optdepends = binutils: --uefi option support
+ optdepends = biosdevname: BIOS network device renaming
optdepends = bluez: bluetooth (keyboard)
optdepends = btrfs-progs: scan for Btrfs on block devices
optdepends = busybox: allows use of busybox (on your own risk)
@@ -59,6 +60,7 @@ pkgbase = dracut-git
optdepends = hardlink: --hardlink option support
optdepends = iproute2: legacy networking support
optdepends = iputils: networking support
+ optdepends = jq: NVMe-oF support (nvmf module)
optdepends = lvm2: support Logical Volume Manager
optdepends = lzop: lzop compression
optdepends = mdadm: support MD devices, also known as software RAID devices
@@ -94,6 +96,7 @@ pkgbase = dracut-git
source = 2544.patch::https://github.com/dracutdevs/dracut/commit/c1a69b81f6ebd62a40054be2375cb77c040694aa.patch
source = 2547-1.patch::https://github.com/dracutdevs/dracut/commit/6da61a2c0e38da4e6e880e1bb7f47d55d2c54c65.patch
source = 2547-2.patch::https://github.com/dracutdevs/dracut/commit/842be0c89fe0cc8cac9efa88e68b07ae1c2d2464.patch
+ source = 2549.patch::https://github.com/dracutdevs/dracut/commit/c20533f9cba63f796d6ee34724e430a712125877.patch
source = 2556.patch::https://github.com/dracutdevs/dracut/commit/19a0ba94275e2d64f6b1a3130f137f626c648939.patch
source = 2565.patch::https://github.com/dracutdevs/dracut/commit/8b3d8c73eba275c01d9714807c10899a5703f656.patch
source = 2593-1.patch::https://github.com/dracutdevs/dracut/commit/ca69cc20833577fac415e36c66495c6dc5b1c721.patch
@@ -110,6 +113,7 @@ pkgbase = dracut-git
sha512sums = 6ec47d79f4363a0c0723480ca8b22a37aad054150f0496af5c54aa17392ab53ca130d8c8849412a5391a9374a232f95571cee799e1296a764964cc5aed000e41
sha512sums = 4845ea5baa480d2b6ab52bc97eeb59a3778857caaefe63e3e4d715c0b727d2c138abe2b367da3bbc21cce14e16873bccd5cfbe21840354d6072360c8a53baf92
sha512sums = 8111a49888257e9d8be72bb60189edb98f57b88c110fb4ef13fd0b0c8ffb524c156169a1271fc70e8f7da21b646978c3975434715be7ca1ba5a08f743203009b
+ sha512sums = a6565ee8bb9c54183078e41c04fb5c29262c3a357a79d5c38bb801f39668ef9f3f56fd4d497208bc5f40ebdfdc82a0b45c52d4e0efb746384dc7f0f48b98c9e4
sha512sums = 191633e5f88743433678e859ad3333273185872a2464c2842341e90edfca1eea14829a00d5bf5db23c2a8a0e56778e631d2f9d67c0f0fe891b409b02d5affba8
sha512sums = 81bcdfc63864fa6b820c78d9b70854998f86d35cb34913b564ce94dcc094e7fc31038ea14a5a5e3870748824b63a24cca8c7db572d6cf7b4e31f30399f3ab064
sha512sums = 295e4847d1a1e8a2d0572ed42b2e992b37aa3875295027fb8b42e128458ed0766a8cd2cb56f455fe863086f357d536b55d9af7f3ff5293b734bd539a1cb86b5c
diff --git a/Dockerfile b/Dockerfile
index d8056854f75d..877f5e4c13e8 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -17,4 +17,7 @@ RUN L=$(paru -Si dracut-git | sed -n '/^Opt/,/^Conf/p' | sed '$d' | sed 's/^Opt.
RUN su build -c 'paru --needed --noconfirm -Syu tgt'
# rebuild to run some tests
-RUN su build -c 'cd ~build/.cache/paru/clone/dracut-git && V=1 TESTS=18 makepkg --force --syncdeps --noconfirm'
+RUN su build -c 'cd ~build/.cache/paru/clone/dracut-git && V=1 TESTS=18 SKIP=" " makepkg --force --syncdeps --noconfirm'
+
+# check SRCINFO
+RUN su build -c 'cd ~build/.cache/paru/clone/dracut-git && makepkg --printsrcinfo > .SRCINFO && updpkgsums && git diff'
diff --git a/PKGBUILD b/PKGBUILD
index b0e2b1c8a4cc..7ef5b0644d28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
pkgname=dracut-git
pkgver=060.r6794.4980bad
-pkgrel=12
+pkgrel=13
pkgdesc='An event driven initramfs infrastructure'
arch=('x86_64')
url='https://github.com/dracutdevs/dracut'
@@ -30,6 +30,7 @@ makedepends=(
)
optdepends=(
'binutils: --uefi option support'
+ 'biosdevname: BIOS network device renaming'
'bluez: bluetooth (keyboard)'
'btrfs-progs: scan for Btrfs on block devices'
'busybox: allows use of busybox (on your own risk)'
@@ -180,7 +181,7 @@ build() {
check() {
cd "${pkgname%-git}/test"
- SKIP=${SKIP-"20 40 50 60 62 63"} TESTS=${TESTS-"18"} KVERSION="$(cd /lib/modules && ls -1 | tail -1)" make check
+ SKIP=${SKIP-"20 50 60 62 63"} TESTS=${TESTS-"18"} KVERSION="$(cd /lib/modules && ls -1 | tail -1)" make check
}
package() {