summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2023-01-09 14:29:15 +0000
committerBruno Pagani2023-01-09 14:29:15 +0000
commit924f8e34307bb3287cd86239237bd5076a6aa895 (patch)
tree7aac96e72e4b7986fcc6d82e032e181db4924cfd
parentbcd158e4e57530eea1d716a06a06fc190ecc20fb (diff)
downloadaur-924f8e34307bb3287cd86239237bd5076a6aa895.tar.gz
FS#77049 produce debug packages
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f59b1168eb17..c5b08696d520 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=f887fa45dfaeeddfe20c9835ae7ca3a0823b661b
_chromiumver=102.0.5005.167
_gcc_patchset=6
# shellcheck disable=SC2034
-pkgrel=2
+pkgrel=3
_major_ver=${pkgver%%.*}
if [[ ${_use_suffix} != 0 ]]; then
@@ -42,7 +42,7 @@ if [[ ${_use_suffix} == 0 ]]; then
provides=("electron${_major_ver}")
fi
# shellcheck disable=SC2034
-options=('!lto') # Electron adds its own flags for ThinLTO
+options=('debug' '!lto') # Electron adds its own flags for ThinLTO
# shellcheck disable=SC2034
source=('git+https://github.com/electron/electron.git'
'git+https://chromium.googlesource.com/chromium/tools/depot_tools.git#branch=main'
@@ -259,7 +259,7 @@ build() {
custom_toolchain = "//build/toolchain/linux/unbundle:default"
host_toolchain = "//build/toolchain/linux/unbundle:default"
clang_use_chrome_plugins = false
- symbol_level = 0
+ symbol_level = 0 # sufficient for backtraces on x86(_64)
chrome_pgo_phase = 2
treat_warnings_as_errors = false
rtc_use_pipewire = true
@@ -273,9 +273,6 @@ build() {
gn gen out/Release \
--args="import(\"//electron/build/args/release.gn\") ${GN_EXTRA_ARGS}"
ninja -C out/Release electron
- # Strip before zip to avoid
- # zipfile.LargeZipFile: Filesize would require ZIP64 extensions
- strip -s out/Release/electron
ninja -C out/Release electron_dist_zip
# ninja -C out/Release third_party/electron_node:headers
}