summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvangelos Foutras2022-12-06 18:44:36 +0000
committerEvangelos Foutras2022-12-06 18:44:36 +0000
commitb2c2eec48847dd2bbb59324e51cee2a8c583d15b (patch)
tree05139f45a10df7e35a6d7b4167a7b3af8ceff741
parentd34c9a0d8088215198ab08a8a4fe7ab7379ae641 (diff)
downloadaur-b2c2eec48847dd2bbb59324e51cee2a8c583d15b.tar.gz
re2 20221201 rebuild
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdae0dd8161f..7fd3082aa7a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=726839761fd57fc23f57a03500f48c2035a6170e
_chromiumver=102.0.5005.167
_gcc_patchset=6
# shellcheck disable=SC2034
-pkgrel=3
+pkgrel=4
_major_ver=${pkgver%%.*}
if [[ ${_use_suffix} != 0 ]]; then
@@ -216,6 +216,9 @@ build() {
export AR=ar
export NM=nm
+ # https://github.com/webpack/webpack/issues/14532
+ export NODE_OPTIONS=--openssl-legacy-provider
+
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
CFLAGS+=' -Wno-builtin-macro-redefined'
CXXFLAGS+=' -Wno-builtin-macro-redefined'