summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-19 00:06:56 +0800
committerChocobo12017-08-19 00:30:01 +0800
commit6dc696a6853e4f92df0724b4167e37b1443e1eb3 (patch)
treec487e9aa1992b4191c5a70d4ba42e4fe115ffb55
downloadaur-6dc696a6853e4f92df0724b4167e37b1443e1eb3.tar.gz
newpkg: expat-git 2.2.3.r39.g2cb09ae-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d039ff80113
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = expat-git
+ pkgdesc = A stream-oriented XML parser library written in C
+ pkgver = 2.2.3.r39.g2cb09ae
+ pkgrel = 1
+ url = https://libexpat.github.io/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ provides = expat
+ conflicts = expat
+ source = git+https://github.com/libexpat/libexpat.git
+ sha256sums = SKIP
+
+pkgname = expat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7629eea9a732
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=expat-git
+pkgver=2.2.3.r39.g2cb09ae
+pkgrel=1
+pkgdesc="A stream-oriented XML parser library written in C"
+arch=('i686' 'x86_64')
+url="https://libexpat.github.io/"
+license=('custom')
+depends=('glibc')
+makedepends=('git' 'cmake')
+provides=('expat')
+conflicts=('expat')
+source=("git+https://github.com/libexpat/libexpat.git")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "libexpat/expat"
+
+ mkdir -p "build"
+}
+
+pkgver() {
+ cd "libexpat/expat"
+
+ git describe --long --tags | sed 's/^R_//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+}
+
+build() {
+ cd "libexpat/expat/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" ../
+ make
+}
+
+check() {
+ cd "libexpat/expat/build"
+
+ make test
+}
+
+package() {
+ cd "libexpat/expat/build"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "../COPYING" "$pkgdir/usr/share/licenses/expat/COPYING"
+}