summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornathanielcwm2020-05-15 08:37:16 +0800
committernathanielcwm2020-05-15 08:37:16 +0800
commit24d765fd9419957fe3f020167ba2a6bf38570799 (patch)
treeeaa278332a9730d943ef128912106bda5731cf41
parent29fd225558907a55257f6cca698c2c158b1702e2 (diff)
downloadaur-24d765fd9419957fe3f020167ba2a6bf38570799.tar.gz
Remove SVT VP9 support
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce7177a22447..51316789e1b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-amd-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)
- pkgver = 4.3.r97441.g36083450a4
+ pkgver = 4.3.r97780.gb18fd2b95b
pkgrel = 1
url = https://www.ffmpeg.org/
arch = i686
@@ -62,7 +62,6 @@ pkgbase = ffmpeg-amd-full-git
depends = libssh
depends = svt-hevc
depends = svt-av1
- depends = svt-vp9
depends = tensorflow
depends = tesseract
depends = libtheora
@@ -130,14 +129,12 @@ pkgbase = ffmpeg-amd-full-git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = ffmpeg-full-git-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = ffmpeg-full-git-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
- source = ffmpeg-full-git-add-svt-av1-0.8.2.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.2/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
- source = ffmpeg-full-git-add-svt-vp9-0.1.0.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v0.1.0/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch
+ source = ffmpeg-full-git-add-svt-av1-0.8.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.3/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
source = LICENSE
sha256sums = SKIP
sha256sums = 878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6
sha256sums = 1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0
sha256sums = d371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f
- sha256sums = 7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-amd-full-git
diff --git a/PKGBUILD b/PKGBUILD
index 0c03c0e055ac..d3c4d46c9bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
_svt_hevc_ver='1.4.3'
-_svt_av1_ver='0.8.2'
-_svt_vp9_ver='0.1.0'
+_svt_av1_ver='0.8.3'
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
-pkgver=4.3.r97441.g36083450a4
+pkgver=4.3.r97780.gb18fd2b95b
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('i686' 'x86_64')
@@ -23,7 +22,7 @@ depends=(
'glslang' 'libgme' 'gsm' 'libiec61883' 'libilbc' 'jack' 'kvazaar' 'lensfun'
'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c'
'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh'
- 'svt-hevc' 'svt-av1' 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
+ 'svt-hevc' 'svt-av1' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
'v4l-utils' 'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264'
'x265' 'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
@@ -51,23 +50,19 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
"ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"ffmpeg-full-git-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch"
- "ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v${_svt_vp9_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch"
'LICENSE')
sha256sums=('SKIP'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
'd371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f'
- '7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
- # add svt codec support for hevc, av1 and vp9
- rm -f ffmpeg/libavcodec/libsvt_{hevc,av1,vp9}.c
- sed -i 's/eb_init_handle/svt_av1_enc_init_handle/' "ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"
+ # add svt codec support for hevc and av1
+ rm -f ffmpeg/libavcodec/libsvt_{hevc,av1}.c
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-av1-${_svt_av1_ver}.patch"
- patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"
}
pkgver() {
@@ -161,7 +156,6 @@ build() {
--enable-libssh \
--enable-libsvthevc \
--enable-libsvtav1 \
- --enable-libsvtvp9 \
--enable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \