summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornathanielcwm2020-04-22 13:04:35 +0800
committernathanielcwm2020-04-22 13:04:35 +0800
commit29fd225558907a55257f6cca698c2c158b1702e2 (patch)
tree0152a59825dbfe8812bd9c5003705723d31dd780
parentef280ff8fdec455b6c61e147c23fdc7542f58edc (diff)
downloadaur-29fd225558907a55257f6cca698c2c158b1702e2.tar.gz
fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a3893c88281..ce7177a22447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-amd-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)
- pkgver = 4.3.r97301.gf1894c206e
+ pkgver = 4.3.r97441.g36083450a4
pkgrel = 1
url = https://www.ffmpeg.org/
arch = i686
@@ -130,13 +130,13 @@ pkgbase = ffmpeg-amd-full-git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = ffmpeg-full-git-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = ffmpeg-full-git-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
- source = ffmpeg-full-git-add-svt-av1-0.8.0.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.0/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
+ source = ffmpeg-full-git-add-svt-av1-0.8.2.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.2/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
source = ffmpeg-full-git-add-svt-vp9-0.1.0.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v0.1.0/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch
source = LICENSE
sha256sums = SKIP
sha256sums = 878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6
sha256sums = 1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0
- sha256sums = efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78
+ sha256sums = d371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f
sha256sums = 7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
diff --git a/PKGBUILD b/PKGBUILD
index 00626b9fe9d7..0c03c0e055ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
_svt_hevc_ver='1.4.3'
-_svt_av1_ver='0.8.0'
+_svt_av1_ver='0.8.2'
_svt_vp9_ver='0.1.0'
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
-pkgver=4.3.r97301.gf1894c206e
+pkgver=4.3.r97441.g36083450a4
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('i686' 'x86_64')
@@ -56,13 +56,14 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
sha256sums=('SKIP'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
- 'efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78'
+ 'd371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f'
'7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
# add svt codec support for hevc, av1 and vp9
rm -f ffmpeg/libavcodec/libsvt_{hevc,av1,vp9}.c
+ sed -i 's/eb_init_handle/svt_av1_enc_init_handle/' "ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-av1-${_svt_av1_ver}.patch"
@@ -89,7 +90,6 @@ build() {
./configure \
--prefix='/usr' \
--extra-cflags="-I/usr/include/tensorflow" \
- --extra-ldflags="$_ldflags" \
\
--disable-rpath \
--enable-gpl \