summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornathanielcwm2020-04-08 12:39:40 +0800
committernathanielcwm2020-04-08 12:39:40 +0800
commit2b05d534b59ace5cedf9851d18aa4988f3582940 (patch)
tree18037abb1fa7dea9d03df2e60f26582914aaefcd
parent41cc5fed92771c0153d878e0911ad88fd62143d0 (diff)
downloadaur-2b05d534b59ace5cedf9851d18aa4988f3582940.tar.gz
Revert "Remove Tensorflow Support"
This reverts commit 41cc5fed92771c0153d878e0911ad88fd62143d0.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecb0ac7ba4f0..041e50f10f8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-amd-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)
pkgver = 4.3.r97205.g3935c891e9
- pkgrel = 3
+ pkgrel = 2
url = https://www.ffmpeg.org/
arch = i686
arch = x86_64
@@ -63,6 +63,7 @@ pkgbase = ffmpeg-amd-full-git
depends = svt-hevc
depends = svt-av1
depends = svt-vp9
+ depends = tensorflow
depends = tesseract
depends = libtheora
depends = twolame
@@ -127,7 +128,6 @@ pkgbase = ffmpeg-amd-full-git
provides = ffmpeg-git
conflicts = ffmpeg
conflicts = doxygen
- conflicts = svt-av1-git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = ffmpeg-full-git-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = ffmpeg-full-git-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
diff --git a/PKGBUILD b/PKGBUILD
index 1add773de0d6..45067af97392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ depends=(
'glslang' 'libgme' 'gsm' 'libiec61883' 'libilbc' 'jack' 'kvazaar' 'lensfun'
'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c'
'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh'
- 'svt-hevc' 'svt-av1' 'svt-vp9' 'tesseract' 'libtheora' 'twolame'
+ 'svt-hevc' 'svt-av1' 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
'v4l-utils' 'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264'
'x265' 'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
@@ -46,7 +46,7 @@ makedepends=(
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libavresample.so' 'libswscale.so'
'libswresample.so' 'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
-conflicts=('ffmpeg' 'doxygen' 'svt-av1-git')
+conflicts=('ffmpeg' 'doxygen')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
"ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
@@ -91,6 +91,8 @@ build() {
./configure \
--prefix='/usr' \
+ --extra-cflags="-I/usr/include/tensorflow" \
+ --extra-ldflags="$_ldflags" \
\
--disable-rpath \
--enable-gpl \
@@ -163,6 +165,7 @@ build() {
--enable-libsvthevc \
--enable-libsvtav1 \
--enable-libsvtvp9 \
+ --enable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \
--disable-libtls \