summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-08-27 18:06:54 +0800
committerChocobo12021-08-27 18:21:27 +0800
commitb65fc3b586e39122ead26dfb4e8b1e93236cd876 (patch)
treefc3da69188825e5a4332ad4419db61e99bd6818f
downloadaur-b65fc3b586e39122ead26dfb4e8b1e93236cd876.tar.gz
newpkg: gd-git 2.3.2.r234.g1b3f6fbe-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD54
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adbfe49668c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = gd-git
+ pkgdesc = A library for the dynamic creation of images
+ pkgver = 2.3.2.r234.g1b3f6fbe
+ pkgrel = 1
+ url = https://libgd.github.io/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ depends = fontconfig
+ depends = freetype2
+ depends = libavif
+ depends = libheif
+ depends = libimagequant
+ depends = libjpeg
+ depends = libpng
+ depends = libtiff
+ depends = libwebp
+ depends = libxpm
+ optdepends = perl: bdftogd script
+ provides = gd
+ conflicts = gd
+ options = staticlibs
+ source = git+https://github.com/libgd/libgd.git
+ sha256sums = SKIP
+
+pkgname = gd-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2951c787c264
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gd-git
+pkgver=2.3.2.r234.g1b3f6fbe
+pkgrel=1
+pkgdesc="A library for the dynamic creation of images"
+arch=('i686' 'x86_64')
+url="https://libgd.github.io/"
+license=('custom')
+depends=('glibc' 'fontconfig' 'freetype2' 'libavif' 'libheif' 'libimagequant' 'libjpeg' 'libpng' 'libtiff' 'libwebp' 'libxpm')
+makedepends=('git' 'cmake')
+optdepends=('perl: bdftogd script')
+provides=('gd')
+conflicts=('gd')
+options=('staticlibs')
+source=("git+https://github.com/libgd/libgd.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libgd"
+
+ git describe --long --tags | sed 's/^gd-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libgd"
+
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_STATIC_LIBS=ON \
+ -DENABLE_FONTCONFIG=ON \
+ -DENABLE_FREETYPE=ON \
+ -DENABLE_GD_FORMATS=ON \
+ -DENABLE_HEIF=ON \
+ -DENABLE_JPEG=ON \
+ -DENABLE_LIQ=ON \
+ -DENABLE_PNG=ON \
+ -DENABLE_TIFF=ON \
+ -DENABLE_WEBP=ON \
+ -DENABLE_XPM=ON \
+ ./
+ make -C "_build"
+}
+
+package() {
+ cd "libgd"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/gd"
+}