summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Astals Cid2021-02-26 15:19:44 +0100
committerAlbert Astals Cid2021-02-26 15:19:44 +0100
commit22f7203192867ac15095affa52af7029143effb6 (patch)
treee9db97406ca5c51d86b8232acb553dfcbd65a0a7
downloadaur-22f7203192867ac15095affa52af7029143effb6.tar.gz
gtk3 but without the dead keys underline
as always use under your responsability ^_^
-rw-r--r--.SRCINFO64
-rw-r--r--PKGBUILD69
-rw-r--r--gtk-query-immodules-3.0.hook11
-rw-r--r--gtk3.install3
-rw-r--r--no_deadkeys_underline.patch13
5 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7a392f8744b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,64 @@
+pkgbase = gtk3-no_deadkeys_underline
+ pkgdesc = Like gtk3 in extra but with a patch to disable dead keys having and underline below them while typing
+ pkgver = 3.24.26
+ pkgrel = 1
+ epoch = 1
+ url = https://www.gtk.org/
+ install = gtk3.install
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = git
+ makedepends = glib2-docs
+ makedepends = sassc
+ makedepends = meson
+ depends = atk
+ depends = cairo
+ depends = libxcursor
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxi
+ depends = libepoxy
+ depends = gdk-pixbuf2
+ depends = dconf
+ depends = libxcomposite
+ depends = libxdamage
+ depends = pango
+ depends = shared-mime-info
+ depends = at-spi2-atk
+ depends = wayland
+ depends = libxkbcommon
+ depends = adwaita-icon-theme
+ depends = json-glib
+ depends = librsvg
+ depends = wayland-protocols
+ depends = desktop-file-utils
+ depends = mesa
+ depends = cantarell-fonts
+ depends = colord
+ depends = rest
+ depends = libcups
+ depends = libcanberra
+ depends = fribidi
+ depends = iso-codes
+ depends = tracker3
+ depends = libcloudproviders
+ depends = gtk-update-icon-cache
+ provides = gtk3-print-backends
+ provides = libgtk-3.so
+ provides = libgdk-3.so
+ provides = libgailutil-3.so
+ provides = gtk3
+ conflicts = gtk3-print-backends
+ conflicts = gtk3
+ replaces = gtk3-print-backends<=3.22.26-1
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=8e9c6171b6efea2880e0bc1bc16ac3208f7a616e
+ source = gtk-query-immodules-3.0.hook
+ source = no_deadkeys_underline.patch
+ sha256sums = SKIP
+ sha256sums = a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229
+ sha256sums = SKIP
+
+pkgname = gtk3-no_deadkeys_underline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbdbac76465c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Based on "upstream" by
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=gtk3-no_deadkeys_underline
+pkgver=3.24.26
+pkgrel=1
+epoch=1
+pkgdesc="Like gtk3 in extra but with a patch to disable dead keys having and underline below them while typing"
+arch=(x86_64)
+url="https://www.gtk.org/"
+depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
+ dconf libxcomposite libxdamage pango shared-mime-info at-spi2-atk
+ wayland libxkbcommon adwaita-icon-theme json-glib librsvg
+ wayland-protocols desktop-file-utils mesa cantarell-fonts colord rest
+ libcups libcanberra fribidi iso-codes tracker3 libcloudproviders
+ gtk-update-icon-cache)
+makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson)
+provides=(gtk3-print-backends libgtk-3.so libgdk-3.so libgailutil-3.so gtk3)
+conflicts=(gtk3-print-backends gtk3)
+replaces=("gtk3-print-backends<=3.22.26-1")
+license=(LGPL)
+install=gtk3.install
+_commit=8e9c6171b6efea2880e0bc1bc16ac3208f7a616e # tags/3.24.26^0
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
+ gtk-query-immodules-3.0.hook
+ no_deadkeys_underline.patch)
+sha256sums=('SKIP'
+ 'a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229'
+ 'SKIP')
+
+pkgver() {
+ cd gtk
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gtk
+ patch -p1 < ../no_deadkeys_underline.patch
+}
+
+build() {
+ CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
+ arch-meson gtk build \
+ -D broadway_backend=true \
+ -D cloudproviders=true \
+ -D colord=yes \
+ -D gtk_doc=true \
+ -D man=true
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+
+ install -Dm644 /dev/stdin "$pkgdir/usr/share/gtk-3.0/settings.ini" <<END
+[Settings]
+gtk-icon-theme-name = Adwaita
+gtk-theme-name = Adwaita
+gtk-font-name = Cantarell 11
+END
+
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook
+
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+ rm "$pkgdir/usr/share/man/man1/gtk-update-icon-cache.1"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gtk-query-immodules-3.0.hook b/gtk-query-immodules-3.0.hook
new file mode 100644
index 000000000000..4d81bd713910
--- /dev/null
+++ b/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = Path
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/gtk3.install b/gtk3.install
new file mode 100644
index 000000000000..c0c44539de6f
--- /dev/null
+++ b/gtk3.install
@@ -0,0 +1,3 @@
+pre_remove() {
+ rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
+}
diff --git a/no_deadkeys_underline.patch b/no_deadkeys_underline.patch
new file mode 100644
index 000000000000..a428b3006f32
--- /dev/null
+++ b/no_deadkeys_underline.patch
@@ -0,0 +1,13 @@
+diff --git a/gtk/gtkimcontextsimple.c b/gtk/gtkimcontextsimple.c
+index 39a659edda..52847a0602 100644
+--- a/gtk/gtkimcontextsimple.c
++++ b/gtk/gtkimcontextsimple.c
+@@ -922,7 +922,7 @@ gtk_im_context_simple_get_preedit_string (GtkIMContext *context,
+ gunichar ch;
+ gboolean need_space;
+
+- if (GDK_KEY_dead_grave <= priv->compose_buffer[i] && priv->compose_buffer[i] <= GDK_KEY_dead_greek)
++ if (FALSE && GDK_KEY_dead_grave <= priv->compose_buffer[i] && priv->compose_buffer[i] <= GDK_KEY_dead_greek)
+ {
+ /* Sadly, not all the dead keysyms have spacing mark equivalents
+ * in Unicode. For those that don't, we use space + the non-spacing