summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-04-25 14:47:23 +1200
committerGeorge Rawlinson2022-04-25 14:47:23 +1200
commit610be76269be2038b89d548b65f114cfccd9555e (patch)
tree08601aeb3a0c2d59515ac564f1bc06f32f98a8f1
downloadaur-610be76269be2038b89d548b65f114cfccd9555e.tar.gz
addpkg: harec r1240-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD49
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c87e2d9100b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = harec
+ pkgdesc = The Hare programming language - bootstrapped compiler
+ pkgver = r1240.c1caaf0
+ pkgrel = 1
+ url = https://harelang.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qbe
+ source = git+https://git.sr.ht/~sircmpwn/harec#commit=c1caaf00bea2415724b969633cca2e3b2b51a4e6
+ b2sums = SKIP
+
+pkgname = harec
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c76611d3703c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=harec
+pkgver=r1240.c1caaf0
+pkgrel=1
+pkgdesc="The Hare programming language - bootstrapped compiler"
+arch=('x86_64')
+url="https://harelang.org/"
+license=('GPL3')
+depends=('qbe')
+makedepends=('git')
+_commit='c1caaf00bea2415724b969633cca2e3b2b51a4e6'
+source=("git+https://git.sr.ht/~sircmpwn/harec#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd harec
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd harec
+
+ # skip failing test
+ sed \
+ -e "/25\-promotion/d" \
+ -i tests/configure
+}
+
+build() {
+ cd harec
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+check() {
+ cd harec
+
+ make check
+}
+
+package() {
+ cd harec
+
+ make DESTDIR="$pkgdir" install
+}