summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Hoffmann2024-01-29 17:09:28 +0100
committerConrad Hoffmann2024-01-29 20:22:03 +0100
commitfc988dc4ad64359c5db3547846041a8118935e1b (patch)
tree4594f0380bc9020933138ca0490ad18bb84e99f4
parentc23e68271fd116ab7d2cfe5dd2767e3bc46c363f (diff)
downloadaur-fc988dc4ad64359c5db3547846041a8118935e1b.tar.gz
Upgrade and depend on qbe-git
There is currently (once more) no released version of qbe that works for with current harec. Also some updates for the make/configuration process.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad64a5cc62cf..46ebf1b904e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = harec
pkgdesc = The Hare programming language - bootstrapped compiler
- pkgver = r1620.f735aba
+ pkgver = r1834.f9e17e6
pkgrel = 1
url = https://harelang.org/
arch = x86_64
arch = aarch64
license = GPL3
makedepends = git
- depends = qbe
- source = git+https://git.sr.ht/~sircmpwn/harec#commit=f735abab4516d2fb729e3ea7aee309eab5a1b0bf
+ depends = qbe-git
+ source = git+https://git.sr.ht/~sircmpwn/harec#commit=f9e17e633845d8d38566b4ea32db0a29ac85d96e
b2sums = SKIP
pkgname = harec
diff --git a/PKGBUILD b/PKGBUILD
index bb98555943ed..f7320101bf6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=harec
-pkgver=r1620.f735aba
+pkgver=r1834.f9e17e6
pkgrel=1
pkgdesc='The Hare programming language - bootstrapped compiler'
arch=('x86_64' 'aarch64')
url='https://harelang.org/'
license=('GPL3')
-depends=('qbe')
+depends=('qbe-git')
makedepends=('git')
-_commit='f735abab4516d2fb729e3ea7aee309eab5a1b0bf'
+_commit='f9e17e633845d8d38566b4ea32db0a29ac85d96e'
source=("git+https://git.sr.ht/~sircmpwn/harec#commit=$_commit")
b2sums=('SKIP')
@@ -19,10 +19,18 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd harec
- ./configure --prefix=/usr
+ # configure prefix directory & architecture
+ sed \
+ -e 's:/usr/local:/usr:' \
+ -e "s/^ARCH = .*/ARCH = $CARCH/" \
+ configs/linux.mk > config.mk
+}
+
+build() {
+ cd harec
make
}