summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-10-31 22:16:17 +0000
committerJonathon Fernyhough2020-10-31 22:16:17 +0000
commitc87291638310b7b8d6f795392d9b7775c98dc482 (patch)
tree11f1be02734c3d208b754d62ea1213ddbb3044ad
downloadaur-c87291638310b7b8d6f795392d9b7775c98dc482.tar.gz
Initial commit for LizziAS
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..024741ebbc02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hypnotix-git
+ pkgdesc = An IPTV app
+ pkgver = r2.5687e0e
+ pkgrel = 1
+ url = https://github.com/linuxmint/hypnotix
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = dconf
+ depends = hicolor-icon-theme
+ depends = python-setproctitle
+ provides = hypnotix
+ conflicts = hypnotix
+ source = git+https://github.com/linuxmint/hypnotix.git
+ b2sums = SKIP
+
+pkgname = hypnotix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d775bc35fea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jonathon Fernyhough <jonathon+m2x@dev>
+
+pkgname=hypnotix-git
+pkgver=r2.5687e0e
+pkgrel=1
+pkgdesc="An IPTV app"
+arch=(any)
+url="https://github.com/linuxmint/hypnotix"
+license=(unknown)
+depends=(dconf hicolor-icon-theme python-setproctitle)
+makedepends=(git)
+provides=(hypnotix)
+conflicts=(hypnotix)
+source=("git+$url.git")
+b2sums=(SKIP)
+
+pkgver() {
+ cd ${pkgname/-git}
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd ${pkgname/-git}
+ make
+}
+
+package() {
+ cd ${pkgname/-git}
+ install -D -t "$pkgdir"/usr/bin usr/bin/hypnotix
+ install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix,mpv}.py
+ install -Dm644 -t "$pkgdir"/usr/share/applications usr/share/applications/hypnotix.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/glib-2.0/schemas usr/share/glib-2.0/schemas/org.x.hypnotix.gschema.xml
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/{hypnotix,shortcuts}.ui
+ install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps usr/share/icons/hicolor/scalable/apps/hypnotix.svg
+}