summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-02-28 14:26:37 +0800
committerChocobo12021-02-28 14:39:42 +0800
commiteeb97de3402bfcd61256388e17dde3d5ef19283b (patch)
tree95e289ccbaf4cfac3c033c357188c88c3cfd68aa
parent39c4e75d19ce524662d469406316f14d002600b0 (diff)
downloadaur-eeb97de3402bfcd61256388e17dde3d5ef19283b.tar.gz
upgpkg: icu-git r33353.ge8dfea9bb6-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d40d95af52b9..c5adacb0c803 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = icu-git
pkgdesc = International Components for Unicode library
- pkgver = 64.2.rc.r29.gbe25c277fd
+ pkgver = r33353.ge8dfea9bb6
pkgrel = 1
url = http://site.icu-project.org/
arch = i686
arch = x86_64
license = custom:icu
makedepends = git
+ makedepends = git-lfs
depends = glibc
depends = sh
provides = icu
+ provides = libicudata.so
+ provides = libicui18n.so
+ provides = libicuio.so
+ provides = libicutest.so
+ provides = libicutu.so
+ provides = libicuuc.so
conflicts = icu
- source = git+https://github.com/unicode-org/icu.git
- sha256sums = SKIP
pkgname = icu-git
diff --git a/PKGBUILD b/PKGBUILD
index 1bfdbecea12d..a65d445ad6e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=icu-git
-pkgver=64.2.rc.r29.gbe25c277fd
+pkgver=r33353.ge8dfea9bb6
pkgrel=1
pkgdesc="International Components for Unicode library"
arch=('i686' 'x86_64')
url="http://site.icu-project.org/"
license=('custom:icu')
depends=('glibc' 'sh')
-makedepends=('git')
-provides=('icu')
+makedepends=('git' 'git-lfs')
+provides=('icu' libicu{data,i18n,io,test,tu,uc}.so)
conflicts=('icu')
-source=("git+https://github.com/unicode-org/icu.git")
-sha256sums=('SKIP')
+_source=("https://github.com/unicode-org/icu.git")
+prepare() {
+ # workaround for `makepkg` failing `git clone` with git-lfs
+ git clone "$_source"
+}
+
pkgver() {
cd "icu"
- git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
}
build() {
@@ -42,5 +48,5 @@ package() {
cd "icu/icu4c/source"
make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/icu/icu4c/LICENSE" "$pkgdir/usr/share/licenses/icu/LICENSE"
+ install -Dm644 "$srcdir/icu/icu4c/LICENSE" -t "$pkgdir/usr/share/licenses/icu"
}