summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-10-07 13:55:37 -0300
committerDaniel Bermond2021-10-07 13:55:37 -0300
commit6d504e4d7a8b25906eee65aed8c3ff3e701e5308 (patch)
treea9247849e1944f2e890bfc1a8df4a07f1d6d708e
parent5c2eeb40217bface1835ea8d3177446bc3ef9f35 (diff)
downloadaur-6d504e4d7a8b25906eee65aed8c3ff3e701e5308.tar.gz
Fix tests. Update backup. Remove jxl (currently does not work).
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3668bfe1c4a3..008859e138b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imagemagick-full-git
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all features, git version)
- pkgver = 7.1.0.2.r11.g81e4de318
+ pkgver = 7.1.0.9.r9.ga3c068017
pkgrel = 1
url = https://www.imagemagick.org/
arch = x86_64
@@ -51,11 +51,9 @@ pkgbase = imagemagick-full-git
makedepends = ttf-dejavu
makedepends = perl
makedepends = libzip
- makedepends = autotrace-nomagick
makedepends = dmalloc
makedepends = flif
makedepends = libfpx
- makedepends = libjxl
makedepends = libumem-git
source = git+https://github.com/ImageMagick/ImageMagick.git#branch=main
source = arch-fonts.diff
@@ -98,14 +96,12 @@ pkgname = imagemagick-full-git
depends = gsfonts
depends = ttf-dejavu
depends = perl
- depends = autotrace-nomagick
depends = dmalloc
depends = flif
depends = libfpx
- depends = libjxl
depends = libumem-git
optdepends = imagemagick-full-doc-git: manual and API docs
- provides = imagemagick=7.1.0.2.r11.g81e4de318
+ provides = imagemagick=7.1.0.9.r9.ga3c068017
provides = imagemagick-git
provides = libmagick
provides = libmagick-git
@@ -123,12 +119,15 @@ pkgname = imagemagick-full-git
backup = etc/ImageMagick-7/policy.xml
backup = etc/ImageMagick-7/quantization-table.xml
backup = etc/ImageMagick-7/thresholds.xml
- backup = etc/ImageMagick-7/type.xml
+ backup = etc/ImageMagick-7/type-apple.xml
backup = etc/ImageMagick-7/type-dejavu.xml
backup = etc/ImageMagick-7/type-ghostscript.xml
+ backup = etc/ImageMagick-7/type-urw-base35.xml
+ backup = etc/ImageMagick-7/type-windows.xml
+ backup = etc/ImageMagick-7/type-.xml
pkgname = imagemagick-full-doc-git
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all features, git version) (manual and API docs)
arch = any
- provides = imagemagick-doc=7.1.0.2.r11.g81e4de318
+ provides = imagemagick-doc=7.1.0.9.r9.ga3c068017
conflicts = imagemagick-doc
diff --git a/PKGBUILD b/PKGBUILD
index e40975750592..f0ffa311c04e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=imagemagick-full-git
pkgname=('imagemagick-full-git' 'imagemagick-full-doc-git')
-pkgver=7.1.0.2.r11.g81e4de318
+pkgver=7.1.0.9.r9.ga3c068017
pkgrel=1
arch=('x86_64')
_qdepth='32'
@@ -30,7 +30,7 @@ makedepends=(
'cairo' 'libpng' 'ghostscript' 'ming' 'librsvg' 'libtiff' 'libwebp' 'libwmf'
'ocl-icd' 'gsfonts' 'ttf-dejavu' 'perl' 'libzip'
# AUR:
- 'autotrace-nomagick' 'dmalloc' 'flif' 'libfpx' 'libjxl' 'libumem-git'
+ 'dmalloc' 'flif' 'libfpx' 'libumem-git'
)
source=('git+https://github.com/ImageMagick/ImageMagick.git#branch=main'
'arch-fonts.diff')
@@ -75,7 +75,7 @@ build() {
--with-x \
--with-zlib \
--with-zstd \
- --with-autotrace \
+ --without-autotrace \
--without-dps \
--with-fftw \
--with-flif \
@@ -89,7 +89,7 @@ build() {
--with-heic \
--with-jbig \
--with-jpeg \
- --with-jxl \
+ --without-jxl \
--with-lcms \
--with-openjp2 \
--with-lqr \
@@ -130,10 +130,10 @@ package_imagemagick-full-git() {
'cairo' 'libpng' 'ghostscript' 'ming' 'librsvg' 'libtiff' 'libwebp' 'libwmf'
'ocl-icd' 'gsfonts' 'ttf-dejavu' 'perl'
# AUR:
- 'autotrace-nomagick' 'dmalloc' 'flif' 'libfpx' 'libjxl' 'libumem-git'
+ 'dmalloc' 'flif' 'libfpx' 'libumem-git'
)
optdepends=('imagemagick-full-doc-git: manual and API docs')
- backup=("etc/ImageMagick-${pkgver%%.*}"/{colors,delegates,log,mime,policy,quantization-table,thresholds,type{,-dejavu,-ghostscript}}.xml)
+ backup=("etc/ImageMagick-${pkgver%%.*}"/{colors,delegates,log,mime,policy,quantization-table,thresholds,type-{apple,dejavu,ghostscript,urw-base35,windows,}}.xml)
options=('!emptydirs' 'libtool')
provides=("imagemagick=${pkgver}" 'imagemagick-git' 'libmagick' 'libmagick-git' 'libmagick-full' 'libmagick-full-git')
conflicts=('imagemagick' 'libmagick')