summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2016-12-03 17:02:14 -0200
committerDaniel Bermond2016-12-03 17:02:14 -0200
commit6f5973f1ebdcff1f2a1cc1cc69f1152ae3546ab6 (patch)
treee0de4c303fcfc947da41455cfc3c1c1a43532777
parent39ec3df78713c8ccfb2d89abacb0da6faeadfe0e (diff)
downloadaur-6f5973f1ebdcff1f2a1cc1cc69f1152ae3546ab6.tar.gz
opencl dependecy changes
In short: depends: changed from ocl-icd to opencl-icd-loader. Moved opencl-headers to makedepends. The long story: This will match the approach used in PKGBUILDs from many repository packages that depends on opencl. These packages doesn't place a direct dependency to package ocl-icd like we were doing here, but instead they depends on libcl or on opencl-icd-loader that is provided by ocl-icd. The imagemagick repository package uses this approach. Also, opencl-headers is not needed at runtime and should be placed in makedepens. It's hard to tell for which one we should replace ocl-icd (if for libcl or for opencl-icd-loader), since, among other things, some repository packages points to libcl and others to opencl-icd-loader. In a recent update the imagemagick repository package has changed dependency from libcl to opencl-icd-loader, so we will be using opencl-icd-loader here too. Reference: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/imagemagick&id=193cd1967d79f4de07019e94cda75aaff9947a3d
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD8
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35bd51c586ab..bf87a55928c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Jul 9 15:14:02 UTC 2016
+# Sat Dec 3 19:01:09 UTC 2016
pkgbase = imagemagick-full-git
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features, Git version)
- pkgver = 7.0.2.3.r11068.g82a1df8
+ pkgver = 7.0.3.9.r11388.g8af0328
pkgrel = 1
url = http://www.imagemagick.org/
arch = i686
arch = x86_64
license = custom
makedepends = git
+ makedepends = opencl-headers
depends = jemalloc
depends = bzip2
depends = libx11
@@ -35,6 +36,7 @@ pkgbase = imagemagick-full-git
depends = openjpeg2
depends = liblqr
depends = xz
+ depends = glu
depends = openexr
depends = pango
depends = libpng
@@ -44,8 +46,7 @@ pkgbase = imagemagick-full-git
depends = libwmf
depends = libxml2
depends = libmpeg2
- depends = opencl-headers
- depends = ocl-icd
+ depends = opencl-icd-loader
optdepends = ttf-mac-fonts: for Apple fonts support
provides = imagemagick
provides = imagemagick-full
diff --git a/PKGBUILD b/PKGBUILD
index 8147efd7e7f7..8b3a4822f8fa 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ _windows_font_dir="/usr/share/fonts/WindowsFonts"
_1st_apple_font_dir="/usr/share/fonts/TTF"
_2nd_apple_font_dir="/usr/share/fonts/Type1"
pkgname=imagemagick-full-git
-pkgver=7.0.2.3.r11068.g82a1df8
+pkgver=7.0.3.9.r11388.g8af0328
pkgrel=1
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features, Git version)"
arch=('i686' 'x86_64')
@@ -30,10 +30,10 @@ url="http://www.imagemagick.org/"
license=('custom')
depends=('jemalloc' 'bzip2' 'libx11' 'libxext' 'libxt' 'libsm' 'zlib' 'autotrace-nomagick' 'fftw' 'flif-git'
'libfpx' 'djvulibre' 'ttf-dejavu' 'fontconfig' 'freetype2' 'libraqm' 'ghostscript' 'gsfonts'
- 'graphviz' 'jbigkit' 'libjpeg-turbo' 'lcms' 'lcms2' 'openjpeg2' 'liblqr' 'xz' 'openexr' 'pango'
- 'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-headers' 'ocl-icd')
+ 'graphviz' 'jbigkit' 'libjpeg-turbo' 'lcms' 'lcms2' 'openjpeg2' 'liblqr' 'xz' 'glu' 'openexr' 'pango'
+ 'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-icd-loader')
optdepends=('ttf-mac-fonts: for Apple fonts support')
-makedepends=('git')
+makedepends=('git' 'opencl-headers')
provides=("imagemagick" "imagemagick-full" "imagemagick-git" "imagemagick-fftw"
"libMagickCore-${pkgver%%.*}.Q32HDRI.so"
"libMagickWand-${pkgver%%.*}.Q32HDRI.so"