summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas P2021-04-21 18:56:43 +0300
committerLeonidas P2021-04-21 18:56:43 +0300
commit4cd2323791a4e40b5689820b9abc51dce7e7d3aa (patch)
treedaeca06080e8d094845120c9f725a73330daa4d8
downloadaur-4cd2323791a4e40b5689820b9abc51dce7e7d3aa.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9131f631f76c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ksmbd-tools
+ pkgdesc = Userspace tools for the cifsd/ksmbd kernel server
+ pkgver = 3.3.9
+ pkgrel = 1
+ url = https://github.com/cifsd-team/ksmbd-tools
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = GPL2
+ depends = ksmbd-dkms
+ source = ksmbd-tools-3.3.9.tar.gz::https://github.com/cifsd-team/ksmbd-tools/archive/3.3.9.tar.gz
+ sha256sums = 7c2c86130912d780df69f26d797d4bd88cf31876a86fdad17032ab684bfe7d8a
+
+pkgname = ksmbd-tools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0494e6bfdb18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Leo Papadakos <jpegxguy@outlook.com>
+
+pkgname=ksmbd-tools
+pkgver=3.3.9
+pkgrel=1
+pkgdesc="Userspace tools for the cifsd/ksmbd kernel server"
+arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
+url="https://github.com/cifsd-team/ksmbd-tools"
+license=('GPL2')
+depends=('ksmbd-dkms')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/cifsd-team/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=("7c2c86130912d780df69f26d797d4bd88cf31876a86fdad17032ab684bfe7d8a")
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
+}