summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKris2017-08-09 12:25:14 -0400
committerKris2017-08-09 12:25:14 -0400
commit592eeb45debde1337c68f75d11003c4452c4c41b (patch)
treed2f1aafd434043d2363fc78e4dbdc33a3ba3e07c
downloadaur-592eeb45debde1337c68f75d11003c4452c4c41b.tar.gz
Init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3635bc4474aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lib32-libzip
+ pkgdesc = A C library for reading, creating, and modifying zip archives
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = http://www.nih.at/libzip/index.html
+ arch = x86_64
+ license = BSD
+ makedepends = gcc-multilib
+ depends = lib32-zlib
+ depends = lib32-glibc
+ options = !libtool
+ source = http://www.nih.at/libzip/libzip-1.2.0.tar.gz
+ sha256sums = 6cf9840e427db96ebf3936665430bab204c9ebbd0120c326459077ed9c907d9f
+
+pkgname = lib32-libzip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd871cfb56ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Kris McCleary <kris27mc@gmail.com>
+
+_pkgname=libzip
+pkgname=lib32-${_pkgname}
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A C library for reading, creating, and modifying zip archives"
+url="http://www.nih.at/libzip/index.html"
+license=('BSD')
+arch=('x86_64')
+depends=('lib32-zlib' 'lib32-glibc')
+makedepends=('gcc-multilib')
+options=('!libtool')
+source=("http://www.nih.at/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('6cf9840e427db96ebf3936665430bab204c9ebbd0120c326459077ed9c907d9f')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ #autoreconf -i
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./configure --build=i386-pc-linux-gnu CFLAGS="-m32 -DNDEBUG" CXXFLAGS="-m32 -DNDEBUG" LDFLAGS=-m32 --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ rm -r "${pkgdir}"/usr/{bin,include,share}
+}