summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoopaKhell2022-07-22 21:06:32 -0400
committerSoopaKhell2022-07-22 21:06:32 -0400
commitcf7506baea03ec6f054add570b6d16a6f983a57c (patch)
treef7f4831b118a8e7c8dcd3b46138579d14e185238
downloadaur-cf7506baea03ec6f054add570b6d16a6f983a57c.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adff9a9104e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libby-git
+ pkgdesc = a simple cli tool to download books from Library Genesis
+ pkgver = r29.fb3dd56
+ pkgrel = 1
+ url = https://github.com/carterprince/libby
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = pup
+ depends = fzf
+ depends = curl
+ depends = wget
+ optdepends = neomutt
+ optdepends = rofi
+ optdepends = ebook-convert
+ provides = libby
+ conflicts = libby
+ source = libby-git::git+https://github.com/carterprince/libby
+ md5sums = SKIP
+
+pkgname = libby-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8849d63d1090
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: carterprince <carteraprince@gmail.com>
+
+pkgname=libby-git
+pkgver=r30.f253e26
+pkgrel=1
+pkgdesc="a simple cli tool to download books from Library Genesis"
+arch=(any)
+url=https://github.com/carterprince/libby
+license=(GPL3)
+depends=(pup fzf curl wget)
+optdepends=('neomutt' 'rofi' 'ebook-convert')
+makedepends=(git)
+provides=(libby)
+conflicts=(libby)
+source=($pkgname::git+https://github.com/carterprince/libby)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir"/$pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"/$pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}