summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-10-07 12:52:44 +0800
committerChocobo12023-10-07 12:56:23 +0800
commitc2ac594a0b492699894deddb8ba370c3b79845a2 (patch)
treedcc543cd8af19624b67018cf87df5012e2fdb044
downloadaur-c2ac594a0b492699894deddb8ba370c3b79845a2.tar.gz
newpkg: libutempter-git 1.2.1.alt1.r14.g9f29181-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7812915a253b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libutempter-git
+ pkgdesc = A library for utmp/wtmp updates
+ pkgver = 1.2.1.alt1.r14.g9f29181
+ pkgrel = 1
+ url = https://github.com/altlinux/libutempter
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = systemd
+ depends = glibc
+ provides = libutempter=1.2.1.alt1.r14.g9f29181
+ conflicts = libutempter
+ source = git+https://github.com/altlinux/libutempter.git
+ sha256sums = SKIP
+
+pkgname = libutempter-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..762c0d0782e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libutempter-git
+pkgver=1.2.1.alt1.r14.g9f29181
+pkgrel=1
+pkgdesc="A library for utmp/wtmp updates"
+arch=('i686' 'x86_64')
+url="https://github.com/altlinux/libutempter"
+license=('LGPL')
+depends=('glibc')
+makedepends=('git' 'systemd')
+provides=("libutempter=$pkgver")
+conflicts=('libutempter')
+source=("git+https://github.com/altlinux/libutempter.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libutempter"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^[0-9\.]+-alt.*$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/-/./'
+}
+
+build() {
+ cd "libutempter/libutempter"
+
+ make
+}
+
+package() {
+ cd "libutempter/libutempter"
+
+ make DESTDIR="$pkgdir" install
+
+ echo 'z /usr/lib/utempter/utempter 2755 root utmp' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/libutempter.conf"
+}