summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuckz@protonmail.ch2021-04-26 02:37:08 -0600
committerDuckz@protonmail.ch2021-04-26 02:37:08 -0600
commit5f2e5bb1cb6d4b8d63196191b78e7b045aee0405 (patch)
tree7e8bb6b96c23213fc4ecec39b4dc7395def983b8
parent4142bf69466eae85292bc20d4547d14c28c168a1 (diff)
downloadaur-5f2e5bb1cb6d4b8d63196191b78e7b045aee0405.tar.gz
had thie right shit but added the wrong shit, wow
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4032c75592c9..3c21fcdf5617 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = lightnovel-crawler-bin
pkgdesc = An app to download novels from online sources and generate e-books.
- pkgver = Lastest_Relese
- pkgrel = 1
+ pkgver = v2.25.1
+ pkgrel = 4
url = https://github.com/dipu-bd/lightnovel-crawler.git
arch = any
license = Apache
- makedepends = git
- depends = python
+ depends = zlib
optdepends = calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr
provides = lncrawl
conflicts = lncrawl
- source = https://github.com/dipu-bd/lightnovel-crawler/releases/latest/download/lncrawl
- md5sums = SKIP
- sha1sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/dipu-bd/lightnovel-crawler/releases/download/v2.25.1/lncrawl
+ md5sums = bbc464d4461315f0c57c1630f8b93767
+ sha1sums = 6ae2c514033976434dad47ac44af89c77b8a6293
+ sha256sums = deea716726839311ff6af8b3e294ed8ba090a19f7dbf676dc8555ccf6d27d7a5
pkgname = lightnovel-crawler-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4aee877763f7..c200a5260a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Robert Manning <duckz@protonmail.ch>
pkgname=lightnovel-crawler-bin
-pkgver=Lastest_Relese
-pkgrel=1
+pkgver=v2.25.1
+pkgrel=4
pkgdesc="An app to download novels from online sources and generate e-books."
arch=('any')
url="https://github.com/dipu-bd/lightnovel-crawler.git"
license=('Apache')
-depends=(python)
-makedepends=(git)
+depends=(zlib)
optdepends=('calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr')
provides=(lncrawl)
conflicts=(lncrawl)
-source=("https://github.com/dipu-bd/lightnovel-crawler/releases/latest/download/lncrawl")
+source=("https://github.com/dipu-bd/lightnovel-crawler/releases/download/$pkgver/lncrawl")
-md5sums=('SKIP')
-sha1sums=('SKIP')
-sha256sums=('SKIP')
+md5sums=('bbc464d4461315f0c57c1630f8b93767')
+sha1sums=('6ae2c514033976434dad47ac44af89c77b8a6293')
+sha256sums=('deea716726839311ff6af8b3e294ed8ba090a19f7dbf676dc8555ccf6d27d7a5')
package() {
- install -D -m755 lncrawl ${pkgdir}/usr/bin/lncrawl
+ install -Dm755 lncrawl ${pkgdir}/usr/bin/lncrawl
}