summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-04-19 05:11:39 +0800
committerlilac2023-04-19 05:11:39 +0800
commit11b2457e10fdbb9f8b0dadaf96f15e70e9be4a39 (patch)
tree958c8fa238cb68be959316a67da93a47676aa089
parent576913e5138bf411daabb989299ab61a74c42199 (diff)
downloadaur-11b2457e10fdbb9f8b0dadaf96f15e70e9be4a39.tar.gz
[lilac] updated to 6.4.2023.04.14-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d3d925f8d80..971aeefb2abc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-amd-drm-next
pkgdesc = Linux kernel next with bleeding edge AMD DRM drivers
- pkgver = 6.3.2023.02.17
- pkgrel = 1
+ pkgver = 6.4.2023.04.14
+ pkgrel = 2
url = https://kernel.org/
arch = x86_64
license = GPL2
@@ -20,10 +20,11 @@ pkgbase = linux-amd-drm-next
makedepends = texlive-latexextra
makedepends = git
options = !strip
- source = linux-amd-drm-next::git+https://gitlab.freedesktop.org/agd5f/linux#tag=amd-drm-next-6.3-2023-02-17
+ options = !debug
+ source = linux-amd-drm-next::git+https://gitlab.freedesktop.org/agd5f/linux#tag=amd-drm-next-6.4-2023-04-14
source = config::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/linux/trunk/config
sha256sums = SKIP
- sha256sums = 81a9379fd2eac51bb2dc69d83737d7fbdd41fcaca5af4873e3666d3c706760d1
+ sha256sums = c8b3fbb7664801bebc2d2d1fdf624524865a7817d0021c55c98523cb58dee201
pkgname = linux-amd-drm-next
pkgdesc = The Linux kernel next with bleeding edge AMD DRM drivers kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 4b9d084c417f..f728bf99855e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Maintainer: heavysink <winstonwu91@gmail.com>
pkgbase=linux-amd-drm-next
-_tag=amd-drm-next-6.3-2023-02-17
-pkgver=6.3.2023.02.17
-pkgrel=1
+_tag='amd-drm-next-6.4-2023-04-14'
+pkgver=6.4.2023.04.14
+pkgrel=2
pkgdesc="Linux kernel next with bleeding edge AMD DRM drivers"
arch=(x86_64)
url="https://kernel.org/"
@@ -14,14 +14,14 @@ makedepends=(
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
-options=('!strip')
+options=('!strip' '!debug')
_srcname=linux-amd-drm-next
source=(
"$_srcname::git+https://gitlab.freedesktop.org/agd5f/linux#tag=$_tag"
config::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/linux/trunk/config # the main kernel config file
)
sha256sums=('SKIP'
- '81a9379fd2eac51bb2dc69d83737d7fbdd41fcaca5af4873e3666d3c706760d1')
+ 'c8b3fbb7664801bebc2d2d1fdf624524865a7817d0021c55c98523cb58dee201')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -29,9 +29,8 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
-
+ sed -i 's/CONFIG_DEBUG_INFO_BTF=y/CONFIG_DEBUG_INFO_BTF=n/g' ../config
echo "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
@@ -49,6 +48,7 @@ prepare() {
make olddefconfig
diff -u ../config .config || :
+ ### Prepared version
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
@@ -103,7 +103,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ # install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include