summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-12-30 12:43:08 +0800
committerlilac2023-12-30 12:43:08 +0800
commit43f34bca9c4b52e01f02efb11d4c185fcce6691e (patch)
tree00312d2d02c54ea4cb5041285deae6352a405b9b
parentcb37a05aeaa1bea2f87d1c79cf237025724c080d (diff)
downloadaur-43f34bca9c4b52e01f02efb11d4c185fcce6691e.tar.gz
[lilac] updated to 6.8.2023.12.15-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec28c366d373..473ef909793a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-amd-drm-next
pkgdesc = Linux kernel next with bleeding edge AMD DRM drivers
- pkgver = 6.7.2023.10.13
- pkgrel = 1
+ pkgver = 6.8.2023.12.15
+ pkgrel = 2
url = https://kernel.org/
arch = x86_64
license = GPL2
@@ -11,13 +11,17 @@ pkgbase = linux-amd-drm-next
makedepends = git
makedepends = libelf
makedepends = pahole
- makedepends = python
makedepends = perl
+ makedepends = python
makedepends = tar
makedepends = xz
+ makedepends = graphviz
+ makedepends = imagemagick
+ makedepends = python-sphinx
+ makedepends = texlive-latexextra
options = !strip
options = !debug
- source = linux-amd-drm-next::git+https://gitlab.freedesktop.org/agd5f/linux#tag=amd-drm-next-6.7-2023-10-13
+ source = linux-amd-drm-next::git+https://gitlab.freedesktop.org/agd5f/linux#tag=amd-drm-next-6.8-2023-12-15
source = config::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/linux/trunk/config
sha256sums = SKIP
sha256sums = 6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da
diff --git a/PKGBUILD b/PKGBUILD
index 7b23e6c45452..ea9ae9661c03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Maintainer: heavysink <winstonwu91@gmail.com>
pkgbase=linux-amd-drm-next
-_tag='amd-drm-next-6.7-2023-10-13'
-pkgver=6.7.2023.10.13
-pkgrel=1
+_tag='amd-drm-next-6.8-2023-12-15'
+pkgver=6.8.2023.12.15
+pkgrel=2
pkgdesc="Linux kernel next with bleeding edge AMD DRM drivers"
arch=(x86_64)
url="https://kernel.org/"
license=(GPL2)
-options=('!strip' '!debug')
makedepends=(
bc
cpio
@@ -17,11 +16,18 @@ makedepends=(
git
libelf
pahole
- python
perl
+ python
tar
xz
+
+ # htmldocs
+ graphviz
+ imagemagick
+ python-sphinx
+ texlive-latexextra
)
+options=('!strip' '!debug')
_srcname=linux-amd-drm-next
source=(
"$_srcname::git+https://gitlab.freedesktop.org/agd5f/linux#tag=$_tag"
@@ -70,6 +76,7 @@ prepare() {
build() {
cd $_srcname
_make all
+ _make htmldocs
}
_package() {
@@ -94,8 +101,8 @@ _package() {
ZSTD_CLEVEL=19 _make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {