summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreggz2024-01-01 15:41:03 +0100
committereggz2024-01-01 15:41:03 +0100
commit44d19d75f6644fcc273ff7e4756dcca849842329 (patch)
tree9a69e11cb10d2eb2fdfdf95fbe95d99c6d493ea8
parent99282761cbe48dcb31daa729bcd4afdbc7715771 (diff)
downloadaur-44d19d75f6644fcc273ff7e4756dcca849842329.tar.gz
Updated
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
-rw-r--r--config.x86_642
-rw-r--r--linux.install37
4 files changed, 7 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e244fc216d55..0ba28fb945fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd-raven
- pkgver = 6.6.v.8
+ pkgver = 6.6.v.9
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -14,20 +14,17 @@ pkgbase = linux-amd-raven
makedepends = lzop
makedepends = gcc>=9.1
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.6.8
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.6.9
source = config.x86_64
source = linux-amd-raven.preset
- source = linux.install
source = more-uarches-for-kernel-5.17+.patch
sha256sums = SKIP
- sha256sums = 3eda67a55bfa5b69de56c851485061e6a70ae68547d7d44259da586738fe4e04
+ sha256sums = 9c2edd2b0e06ff6346204b9dcea2fb558359104d67541c093ab601c445e8bc5a
sha256sums = fd220b9f47a86162247b042f06311848678f9acb64b92f716572972f3aeb3d18
- sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = 81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe
pkgname = linux-amd-raven
pkgdesc = Linux kernel with working amdgpu for Raven Ridge hardware
- install = linux.install
depends = coreutils
depends = linux-firmware
depends = kmod
diff --git a/PKGBUILD b/PKGBUILD
index cb42f24d9880..1ac1d37eb4bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-raven
_srcname=linux
-gitver=v6.6.8
+gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
-pkgver=6.6.v.8
+pkgver=6.6.v.9
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -19,17 +19,13 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
# linux package install directives for pacman
- 'linux.install'
- # patch from graysky (https://github.com/graysky2/kernel_compiler_patch/) hosted on gentoo
'more-uarches-for-kernel-5.17+.patch'
)
sha256sums=('SKIP'
#config.x86_64
- '3eda67a55bfa5b69de56c851485061e6a70ae68547d7d44259da586738fe4e04'
+ '9c2edd2b0e06ff6346204b9dcea2fb558359104d67541c093ab601c445e8bc5a'
#.preset file
'fd220b9f47a86162247b042f06311848678f9acb64b92f716572972f3aeb3d18'
- #linux install file
- 'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#grayskypatch file
'81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe'
)
@@ -49,9 +45,6 @@ prepare() {
exit 2
fi
- # don't run depmod on 'make install'. We'll do this ourselves in packaging
- sed -i '2iexit 0' scripts/depmod.sh
-
# Implement all packaged patches and reverts. Ignore errors.
msg2 "Implementing custom kernel patches/reverts"
while read patch; do
@@ -87,7 +80,6 @@ _package() {
depends=('coreutils' 'linux-firmware' 'kmod' 'lzop')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
- install=linux.install
cd "${_srcname}"
@@ -102,14 +94,6 @@ _package() {
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
- # set correct depmod command for install
- cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
- true && install=${install}.pkg
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
- -i "${startdir}/${install}"
-
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
@@ -123,14 +107,6 @@ _package() {
rm -f "${pkgdir}"/lib/modules/${_kernver}/build
# remove the firmware
rm -rf "${pkgdir}/lib/firmware"
- # make room for external modules
- ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
- # add real version for building modules and running depmod from post_install/upgrade
- mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}"
- echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}/version"
-
- # Now we call depmod...
- depmod -b "${pkgdir}" -F System.map "${_kernver}"
# move module tree /lib -> /usr/lib
mkdir -p "${pkgdir}/usr"
diff --git a/config.x86_64 b/config.x86_64
index f754b4d8d730..d245434ea2e1 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.6.8 Kernel Configuration
+# Linux/x86 6.6.9 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.2.1 20230801"
CONFIG_CC_IS_GCC=y
diff --git a/linux.install b/linux.install
deleted file mode 100644
index ef42413835ac..000000000000
--- a/linux.install
+++ /dev/null
@@ -1,37 +0,0 @@
-# arg 1: the new package version
-# arg 2: the old package version
-
-KERNEL_NAME=
-KERNEL_VERSION=
-
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-}
-
-post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
-}
-
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/initramfs-linux${KERNEL_NAME}.img
- rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
-}