summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreggz2024-01-03 10:09:26 +0100
committereggz2024-01-03 10:09:26 +0100
commite99f27cfdade9f6555104d50c7d6d6ae3bd2e82e (patch)
tree5defebd52448d89ac06c48e9b18894b2d626e2ec
parent44d19d75f6644fcc273ff7e4756dcca849842329 (diff)
downloadaur-e99f27cfdade9f6555104d50c7d6d6ae3bd2e82e.tar.gz
remove extra kernelcopy and docs package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 3 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ba28fb945fb..02c4add5d854 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-raven
pkgver = 6.6.v.9
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -34,6 +34,3 @@ pkgname = linux-amd-raven
pkgname = linux-amd-raven-headers
pkgdesc = Header files and scripts for building modules for Linux kerel with working amdgpu for Raven Ridge hardware
-
-pkgname = linux-amd-raven-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel
diff --git a/PKGBUILD b/PKGBUILD
index 1ac1d37eb4bf..5bc09fec9151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
pkgver=6.6.v.9
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -92,7 +92,6 @@ _package() {
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
- cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
@@ -205,22 +204,7 @@ _package-headers() {
done <<< $(find "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/ -maxdepth 1 -mindepth 1 -type d | grep -v /x86$)
}
-_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel"
-
- cd "${_srcname}"
-
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
- cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"
- find "${pkgdir}" -type f -exec chmod 444 {} \;
- find "${pkgdir}" -type d -exec chmod 755 {} \;
-
- # remove a file already in linux package
- rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
-
-}
-
-pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")
+pkgname=("${pkgbase}" "${pkgbase}-headers")
for _p in ${pkgname[@]}; do
eval "package_${_p}() {
$(declare -f "_package${_p#${pkgbase}}")