summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-06-22 20:38:26 +0200
committerPiotr Gorski2023-06-22 20:38:26 +0200
commitf93da7a99d3cd2be1cd87d6dad53731092c7f5b0 (patch)
treef95cd56a10e2a2663f4fbfc4ea0bb13700b2e244
parent75cbbe86391ce02fbb80a9bbf2ebaa1c8edfd294 (diff)
downloadaur-f93da7a99d3cd2be1cd87d6dad53731092c7f5b0.tar.gz
Bump to 6.1.35-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
-rw-r--r--config4
3 files changed, 37 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 536e803147b2..7f6eb4f3c70c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cachyos-lts
pkgdesc = Linux BORE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.1.29
+ pkgver = 6.1.35
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -22,18 +22,18 @@ pkgbase = linux-cachyos-lts
makedepends = patch
makedepends = python
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.29.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.35.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.1/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.1/misc/0001-Add-latency-priority-for-CFS-class.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.1/sched/0001-bore-cachy.patch
- sha256sums = 1e736cc9bd6036379a1d915e518abd4c2c94ad0fd1ea0da961c3489308b8fcfb
- sha256sums = b00fb5dc7c5079c3efa1d0ee3b419376cf053c4b90ed623405096ce880e3dc8c
+ sha256sums = be368143bc5d0dc73dd3e8c6191630c1620520379baf6f47c16116b2c0bc26ac
+ sha256sums = 7dc7094a6188e0522cbe820963cadad83125abdd3c888d9a43704079ccf442b3
sha256sums = 41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106
- sha256sums = 0e0407321ff805d253a2d81a47e0df0a8087869d3c5902af03b7d12ee6981147
- sha256sums = f3978876414beee18d6e80995b01b3d3dca1bb6bca9beacf8ac28e2ec6b08ede
- sha256sums = 69f88ce35468d190badf5e781120f16f44b416c580d22d79194d52ee29e6ce6f
+ sha256sums = 9669e0c18786d5b07a38a7da14bc653c1cf43e2765a047f1d33ecb5c0ee5369d
+ sha256sums = 8811cdc9215a0dfff3a922a2f9eadefb6760bfb78fb756adc88d5894403148f0
+ sha256sums = 77644defe33dc78257f2f6db76b1ec9265a08e141cc177b8bf0a37ce7c8b79b5
pkgname = linux-cachyos-lts
pkgdesc = The Linux BORE scheduler Kernel by CachyOS with other patches and improvements kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 56ab02c5a93f..fa9a51c74847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,6 +60,10 @@ _use_current=${_use_current-}
### Enable KBUILD_CFLAGS -O3
_cc_harder=${_cc_harder-y}
+### Enable KBUILD_CFLAGS -Os
+## DO NOT SET, THIS IS FOR INTERNAL CI USE ONLY.
+_cc_size=${_cc_size-}
+
### Set this to your number of threads you have in your machine otherwise it will default to 128
_nr_cpus=${_nr_cpus-}
@@ -197,7 +201,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.1
-_minor=29
+_minor=35
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -306,7 +310,7 @@ prepare() {
### Select CPU optimization
if [ -n "$_processor_opt" ]; then
- MARCH=$(echo $_processor_opt|tr '[:lower:]' '[:upper:]'&&echo)
+ MARCH="${_processor_opt^^}"
MARCH2=M${MARCH}
scripts/config -k -d CONFIG_GENERIC_CPU
scripts/config -k -e CONFIG_${MARCH2}
@@ -335,8 +339,7 @@ prepare() {
*) _die "The value $_cpusched is invalid. Choose the correct one again.";;
esac
- local sched_name="$(echo $_cpusched|tr '[:lower:]' '[:upper:]')"
- echo "Selecting ${sched_name} CPU scheduler..."
+ echo "Selecting ${_cpusched^^} CPU scheduler..."
### Enable KCFI
if [ -n "$_use_kcfi" ]; then
@@ -453,12 +456,19 @@ prepare() {
echo "Selecting '$_preempt' preempt type..."
### Enable O3
- if [ -n "$_cc_harder" ]; then
+ if [ -n "$_cc_harder" ] && [ -z "$_cc_size" ]; then
echo "Enabling KBUILD_CFLAGS -O3..."
scripts/config -d CC_OPTIMIZE_FOR_PERFORMANCE \
-e CC_OPTIMIZE_FOR_PERFORMANCE_O3
fi
+ ### Enable Os
+ if [ -n "$_cc_size" ] && [ -z "$_cc_harder" ]; then
+ echo "Enabling KBUILD_CFLAGS -Os..."
+ scripts/config -d CC_OPTIMIZE_FOR_PERFORMANCE \
+ -e CONFIG_CC_OPTIMIZE_FOR_SIZE
+ fi
+
### Enable bbr2
if [ -n "$_tcp_bbr2" ]; then
echo "Disabling TCP_CONG_CUBIC..."
@@ -467,6 +477,14 @@ prepare() {
-e TCP_CONG_BBR2 \
-e DEFAULT_BBR2 \
--set-str DEFAULT_TCP_CONG bbr2
+
+ # BBR2 doesn't work properly with FQ_CODEL
+ echo "Disabling fq_codel by default..."
+ scripts/config -m NET_SCH_FQ_CODEL \
+ -e NET_SCH_FQ \
+ -d DEFAULT_FQ_CODEL \
+ -e DEFAULT_FQ \
+ --set-str DEFAULT_NET_SCH fq
fi
### Select LRU config
@@ -846,9 +864,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('1e736cc9bd6036379a1d915e518abd4c2c94ad0fd1ea0da961c3489308b8fcfb'
- 'b00fb5dc7c5079c3efa1d0ee3b419376cf053c4b90ed623405096ce880e3dc8c'
+sha256sums=('be368143bc5d0dc73dd3e8c6191630c1620520379baf6f47c16116b2c0bc26ac'
+ '7dc7094a6188e0522cbe820963cadad83125abdd3c888d9a43704079ccf442b3'
'41c34759ed248175e905c57a25e2b0ed09b11d054fe1a8783d37459f34984106'
- '0e0407321ff805d253a2d81a47e0df0a8087869d3c5902af03b7d12ee6981147'
- 'f3978876414beee18d6e80995b01b3d3dca1bb6bca9beacf8ac28e2ec6b08ede'
- '69f88ce35468d190badf5e781120f16f44b416c580d22d79194d52ee29e6ce6f')
+ '9669e0c18786d5b07a38a7da14bc653c1cf43e2765a047f1d33ecb5c0ee5369d'
+ '8811cdc9215a0dfff3a922a2f9eadefb6760bfb78fb756adc88d5894403148f0'
+ '77644defe33dc78257f2f6db76b1ec9265a08e141cc177b8bf0a37ce7c8b79b5')
diff --git a/config b/config
index 8a8b4502575a..a1865d281a1c 100644
--- a/config
+++ b/config
@@ -1217,8 +1217,8 @@ CONFIG_HAVE_ARCH_USERFAULTFD_WP=y
CONFIG_HAVE_ARCH_USERFAULTFD_MINOR=y
CONFIG_PTE_MARKER=y
CONFIG_PTE_MARKER_UFFD_WP=y
-# CONFIG_LRU_GEN is not set
-# CONFIG_LRU_GEN_ENABLED is not set
+CONFIG_LRU_GEN=y
+CONFIG_LRU_GEN_ENABLED=y
# CONFIG_LRU_GEN_STATS is not set
CONFIG_ARCH_SUPPORTS_PER_VMA_LOCK=y
# CONFIG_PER_VMA_LOCK is not set