summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2023-12-04 01:18:49 +0100
committerJoan Figueras2023-12-04 01:18:49 +0100
commit1c48635ead3fa4da9fa21905528a604013396ff7 (patch)
tree2d45af7b51fcd5eb3a071ea1fb4a68a7a2dfe443
parent202a4e124ca194b0b7c1e1d3f208fffc3a5e692e (diff)
downloadaur-1c48635ead3fa4da9fa21905528a604013396ff7.tar.gz
6.6.4-xanmod1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD61
2 files changed, 54 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 152755193845..7a7db4e23aba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,44 @@
pkgbase = linux-xanmod
pkgdesc = Linux Xanmod - Stable Mainline [MAIN]
- pkgver = 6.5.13
+ pkgver = 6.6.4
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
makedepends = bc
makedepends = cpio
- makedepends = kmod
+ makedepends = gettext
makedepends = libelf
+ makedepends = pahole
makedepends = perl
+ makedepends = python
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.5.tar.xz
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.5.tar.sign
- source = patch-6.5.13-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/main/6.5.13-xanmod1/patch-6.5.13-xanmod1.xz/download
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.tar.sign
+ source = patch-6.6.4-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/main/6.6.4-xanmod1/patch-6.6.4-xanmod1.xz/download
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 7a574bbc20802ea76b52ca7faf07267f72045e861b18915c5272a98c27abf884
+ sha256sums = d926a06c63dd8ac7df3f86ee1ffc2ce2a3b81a2d168484e76b5b389aba8e56d0
sha256sums = SKIP
- sha256sums = 9056062aee2045b5cd68c1a043d96dc8dd4793aa87ac394a103f369fbf64d7fd
+ sha256sums = ce833776671df7b8f366f79b3e7f1fbffc967d7e8ad5c055c4e2e7f81c9d4f75
sha256sums = a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f
pkgname = linux-xanmod
pkgdesc = The Linux kernel and modules with Xanmod patches
depends = coreutils
- depends = kmod
depends = initramfs
- optdepends = crda: to set the correct wireless channels of your country
+ depends = kmod
+ optdepends = wireless-regdb: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
+ provides = KSMBD-MODULE
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- provides = KSMBD-MODULE
provides = NTFS3-MODULE
+ replaces = virtualbox-guest-modules-arch
+ replaces = wireguard-arch
pkgname = linux-xanmod-headers
pkgdesc = Headers and scripts for building modules for the Linux Xanmod - Stable Mainline [MAIN] kernel
diff --git a/PKGBUILD b/PKGBUILD
index 5f2dcaf17f09..6a869463a4d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Joan Figueras <ffigue at gmail dot com>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
##
## The following variables can be customized at build time. Use env or export to change at your wish
@@ -72,8 +72,8 @@ fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod
-_major=6.5
-pkgver=${_major}.13
+_major=6.6
+pkgver=${_major}.4
_branch=6.x
xanmod=1
_revision=
@@ -85,7 +85,15 @@ arch=(x86_64)
license=(GPL2)
makedepends=(
- bc cpio kmod libelf perl tar xz
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
if [ "${_compiler}" = "clang" ]; then
makedepends+=(clang llvm lld python)
@@ -105,13 +113,12 @@ validpgpkeys=(
_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
_patches=()
for _patch in ${_patches[@]}; do
- #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
-sha256sums=('7a574bbc20802ea76b52ca7faf07267f72045e861b18915c5272a98c27abf884'
+sha256sums=('d926a06c63dd8ac7df3f86ee1ffc2ce2a3b81a2d168484e76b5b389aba8e56d0'
'SKIP'
- '9056062aee2045b5cd68c1a043d96dc8dd4793aa87ac394a103f369fbf64d7fd'
+ 'ce833776671df7b8f366f79b3e7f1fbffc967d7e8ad5c055c4e2e7f81c9d4f75'
'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -235,17 +242,28 @@ build() {
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES
- WIREGUARD-MODULE
- KSMBD-MODULE
- NTFS3-MODULE)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ NTFS3-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
cd linux-${_major}
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -256,10 +274,11 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
@@ -324,7 +343,7 @@ _package-headers() {
msg2 "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -338,7 +357,7 @@ _package-headers() {
msg2 "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
-
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"