summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodolfo Panerai2020-11-28 19:02:42 +0100
committerRodolfo Panerai2020-11-28 19:02:42 +0100
commit7c909f9a4f203c9b0f346f843dcaaa709c07612a (patch)
tree70680ca12777d569ead977fd51e526e48cbe23ca
downloadaur-7c909f9a4f203c9b0f346f843dcaaa709c07612a.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD31
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c5cc88027e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = megasync-bin
+ pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive
+ pkgver = 4.3.8
+ pkgrel = 1
+ url = https://mega.nz
+ arch = x86_64
+ license = custom
+ depends = glibc
+ depends = gcc-libs
+ depends = qt5-base
+ depends = qt5-tools
+ depends = icu
+ depends = sqlite
+ depends = openssl
+ depends = zlib
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = bzip2
+ depends = xz
+ depends = libraw
+ depends = double-conversion
+ optdepends = sni-qt: fix systray issue on KDE and LXQt
+ provides = megasync
+ source = https://mega.nz/linux/MEGAsync/Arch_Extra/x86_64/megasync-4.3.8-1-x86_64.pkg.tar.zst
+ sha256sums = 7b3adc8cf17435e8bf93d0f51f42057ed621259181a04ca55e7162336eb01937
+
+pkgname = megasync-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18b5eb081fed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rodolfo Panerai <rodolfo.panerai at gmail dot com>
+pkgname=megasync-bin
+pkgver=4.3.8
+pkgrel=1
+pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive"
+arch=('x86_64')
+url="https://mega.nz"
+license=('custom')
+provides=('megasync')
+depends=('glibc'
+ 'gcc-libs'
+ 'qt5-base'
+ 'qt5-tools'
+ 'icu'
+ 'sqlite'
+ 'openssl'
+ 'zlib'
+ 'qt5-svg'
+ 'qt5-x11extras'
+ 'bzip2'
+ 'xz'
+ 'libraw'
+ 'double-conversion')
+optdepends=('sni-qt: fix systray issue on KDE and LXQt')
+source=("${url}/linux/MEGAsync/Arch_Extra/x86_64/megasync-${pkgver}-${pkgrel}-x86_64.pkg.tar.zst")
+sha256sums=('7b3adc8cf17435e8bf93d0f51f42057ed621259181a04ca55e7162336eb01937')
+
+package() {
+ cp -R "${srcdir}/usr" "${pkgdir}/"
+ rm -rf "${pkgdir}/usr/share/icons/ubuntu-mono-dark"
+}