summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Gregory2015-06-12 14:40:45 -0400
committerAndrew Gregory2015-06-12 14:40:45 -0400
commit374c1d35fbcb147419de9e38286ef9199914cbcc (patch)
tree1a51072b2d1f5935a0124f5038c6469bbd93a55d
downloadaur-374c1d35fbcb147419de9e38286ef9199914cbcc.tar.gz
add openrc v0.16.4
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD55
-rw-r--r--openrc.logrotate7
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b5be0b24845
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = openrc
+ pkgdesc = Dependency based init system that works with sysvinit.
+ pkgver = 0.16.4
+ pkgrel = 1
+ url = http://www.gentoo.org/proj/en/base/openrc/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = openrc-sysvinit
+ depends = pam
+ depends = sh
+ optdepends = openrc-arch-services-git: collection of services for Arch
+ optdepends = net-tools: for network service support
+ backup = etc/openrc/inittab
+ backup = etc/openrc/rc.conf
+ backup = etc/openrc/conf.d/bootmisc
+ backup = etc/openrc/conf.d/consolefont
+ backup = etc/openrc/conf.d/devfs
+ backup = etc/openrc/conf.d/dmesg
+ backup = etc/openrc/conf.d/fsck
+ backup = etc/openrc/conf.d/hostname
+ backup = etc/openrc/conf.d/hwclock
+ backup = etc/openrc/conf.d/keymaps
+ backup = etc/openrc/conf.d/killprocs
+ backup = etc/openrc/conf.d/localmount
+ backup = etc/openrc/conf.d/modules
+ backup = etc/openrc/conf.d/netmount
+ backup = etc/openrc/conf.d/network
+ backup = etc/openrc/conf.d/staticroute
+ backup = etc/openrc/conf.d/tmpfiles
+ backup = etc/openrc/conf.d/urandom
+ source = http://dev.gentoo.org/~williamh/dist/openrc-0.16.4.tar.bz2
+ source = openrc.logrotate
+ md5sums = 99ebfca306184cae36b77ceaeaf1fa76
+ md5sums = ede356beae529d1b16b769c9da70ad52
+
+pkgname = openrc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d725ba4cf0d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d70377e37b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Andrew Gregory <andrew.gregory.8@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=openrc
+pkgver=0.16.4
+pkgrel=1
+pkgdesc='Dependency based init system that works with sysvinit.'
+arch=('i686' 'x86_64')
+url='http://www.gentoo.org/proj/en/base/openrc/'
+license=('BSD')
+depends=('openrc-sysvinit' 'pam' 'sh')
+optdepends=('openrc-arch-services-git: collection of services for Arch'
+ 'net-tools: for network service support')
+backup=(etc/openrc/inittab
+ etc/openrc/rc.conf
+ etc/openrc/conf.d/{bootmisc,consolefont,devfs,dmesg,fsck,hostname,hwclock,keymaps}
+ etc/openrc/conf.d/{killprocs,localmount,modules,netmount,network,staticroute}
+ etc/openrc/conf.d/{tmpfiles,urandom})
+source=(http://dev.gentoo.org/~williamh/dist/$pkgname-$pkgver.tar.bz2
+ $pkgname.logrotate)
+md5sums=('99ebfca306184cae36b77ceaeaf1fa76'
+ 'ede356beae529d1b16b769c9da70ad52')
+
+_makeargs=(BRANDING='Arch Linux')
+_makeargs+=(MKPAM=pam)
+_makeargs+=(MKSELINUX=no)
+_makeargs+=(MKTERMCAP=ncurses)
+_makeargs+=(PKG_PREFIX="")
+_makeargs+=(LIBDIR=/usr/lib)
+_makeargs+=(LIBMODE=0644) # enable binary stripping by makepkg
+_makeargs+=(SHLIBDIR=/usr/lib)
+_makeargs+=(LIBEXECDIR=/usr/libexec/rc)
+_makeargs+=(BINDIR=/usr/bin)
+_makeargs+=(SBINDIR=/usr/bin)
+_makeargs+=(SYSCONFDIR=/etc/openrc) # avoid conflict with initscripts
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make "${_makeargs[@]}"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" "${_makeargs[@]}" install
+
+ # default path to inittab conflicts with initscripts
+ #install -m 644 support/sysvinit/inittab "$pkgdir"/etc/inittab
+
+ # avoid initscripts conflict, requires openrc-sysvinit
+ install -m 644 support/sysvinit/inittab "$pkgdir/etc/openrc/inittab"
+
+ # rotate boot log
+ install -Dm0644 "$srcdir/$pkgname.logrotate" "$pkgdir/etc/logrotate.d/$pkgname"
+}
diff --git a/openrc.logrotate b/openrc.logrotate
new file mode 100644
index 000000000000..a168f2361b38
--- /dev/null
+++ b/openrc.logrotate
@@ -0,0 +1,7 @@
+/var/log/rc.log {
+ compress
+ rotate 4
+ weekly
+ missingok
+ notifempty
+}