summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-12-01 16:49:32 +0100
committerMarco Rubin2022-12-01 16:49:32 +0100
commitd82d730408cc040b2f8c727c1697ceb36468f347 (patch)
tree64beb203d700b089967225a6e48a6958aede0416
parente5a00d2671b8f424775c069f2b4ca187e6a1d695 (diff)
downloadaur-d82d730408cc040b2f8c727c1697ceb36468f347.tar.gz
Added
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4faa65a5879c..3d36bff435fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrc
pkgdesc = Dependency based init system that works with sysvinit and systemd or on its own.
pkgver = 0.45.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OpenRC/openrc
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = openrc
optdepends = net-tools: for network service support
optdepends = opentmpfiles: adds support for systemd-style tmpfiles.d
optdepends = bash-completion: tab completion for openrc commands in bash shells
+ optdepends = zsh-completions: tab completion for openrc commands in zsh shells
provides = openrc
provides = librc.so
provides = init-rc
diff --git a/PKGBUILD b/PKGBUILD
index 7323eb72dfbd..64ffe9fc8da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=openrc
pkgver=0.45.2
-pkgrel=1
+pkgrel=2
pkgdesc='Dependency based init system that works with sysvinit and systemd or on its own.'
arch=('i686' 'x86_64')
url='https://github.com/OpenRC/openrc'
@@ -15,7 +15,8 @@ depends=('pam')
optdepends=('openrc-arch-services-git: collection of services for Arch'
'net-tools: for network service support'
'opentmpfiles: adds support for systemd-style tmpfiles.d'
- 'bash-completion: tab completion for openrc commands in bash shells')
+ 'bash-completion: tab completion for openrc commands in bash shells'
+ 'zsh-completions: tab completion for openrc commands in zsh shells')
makedepends=('meson' 'pam' 'psmisc')
provides=('openrc' 'librc.so' 'init-rc' 'libeinfo.so' 'svc-manager')
conflicts=('openrc')
@@ -36,10 +37,12 @@ prepare() {
build() {
cd $pkgname-$pkgver
+ # libexecdir and sbindir: overwrite arch-meson defaults
# sysconfdir: avoid conflicts with other init systems
arch-meson \
--libexecdir=/usr/libexec/rc \
--sbindir=/usr/bin \
+ -Dbash-completions=true \
-Dbranding='"Arch Linux"' \
-Dos=Linux \
-Dpam=true \
@@ -48,6 +51,7 @@ build() {
-Dselinux=disabled \
-Dsysconfdir=/etc/openrc \
-Dtermcap=ncurses \
+ -Dzsh-completions=true \
build
meson compile -C build
}
@@ -57,7 +61,7 @@ package() {
meson install -C build --destdir "$pkgdir"
# default path to inittab conflicts with initscripts
- # install -Dm644 support/sysvinit/inittab "$pkgdir"/etc/inittab
+ # install -Dm644 support/sysvinit/inittab "$pkgdir/etc/inittab"
# avoid initscripts conflict, requires openrc-sysvinit
install -Dm644 support/sysvinit/inittab "$pkgdir/etc/openrc/inittab"