summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-03-19 15:38:51 +1300
committerGeorge Rawlinson2022-03-19 15:38:51 +1300
commitfcda9603fc7d7661e01f4adc6bc6366432e02b83 (patch)
treecb5ded7d4b842f256eb5772ca320b812b958ff30
downloadaur-fcda9603fc7d7661e01f4adc6bc6366432e02b83.tar.gz
addpkg: opentyrian2000 2000.20200917-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD65
-rw-r--r--update-paths.patch110
3 files changed, 198 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f5b613c1241
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = opentyrian2000
+ pkgdesc = Open Source port of the classic DOS shoot-em-up Tyrian2000
+ pkgver = 2000.20200917
+ pkgrel = 1
+ url = https://github.com/KScl/opentyrian2000
+ arch = x86_64
+ license = GPL2
+ license = custom:Freeware
+ makedepends = git
+ depends = sdl2
+ depends = sdl2_net
+ depends = hicolor-icon-theme
+ source = opentyrian2000::git+https://github.com/KScl/opentyrian2000.git#commit=7bf22d97a19350fbf631aecb9742ee85b65c2be4
+ source = opentyrian2000-assets.zip::https://camanis.net/tyrian/tyrian2000.zip
+ source = update-paths.patch
+ sha512sums = SKIP
+ sha512sums = b425b8524e408b128e249d2916597bd5bebd34ee418e3ddbe13306e1f86869eaba85db0ae5a5dbae4d477b7fec6e04e8fb292d516bba7aff96cf2795232dbfc1
+ sha512sums = ae9567f32540ae18d345cc8070dc544b13141e7f41b002aeb12f63497ce58e0f5bdb7b017fd2719d0def5bc3533c2147bdf9cf7c5eb75809603a6b5c9cdba46b
+ b2sums = SKIP
+ b2sums = 942ee68be24944e3d65612f323cd884e357341db42ee4ed5f487c7d1d650ab4bef98121dbdd321840bc3046f94c9491a6d777179821ba83ce0b4ad7573778aab
+ b2sums = 2d942ae0bcb609143f3684d922e39fa39066f3c9f6ce27b28376a5cf27f294c31dbeadd2cb495135051c3a22bd11bd489dbe4a73a183bb6f93ded9de7a83eb9d
+
+pkgname = opentyrian2000
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e2b37866500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=opentyrian2000
+pkgver=2000.20200917
+pkgrel=1
+pkgdesc='Open Source port of the classic DOS shoot-em-up Tyrian2000'
+url="https://github.com/KScl/opentyrian2000"
+arch=('x86_64')
+# refs for asset licensing:
+# https://www.camanis.net/
+# https://web.archive.org/web/20120218200015/http://www.freewebs.com/worldtreegames
+# https://lostgarden.home.blog/2007/04/05/free-game-graphics-tyrian-ships-and-tiles/
+# https://lostgarden.home.blog/2007/03/15/lost-garden-license/
+license=('GPL2' 'custom:Freeware')
+depends=('sdl2' 'sdl2_net' 'hicolor-icon-theme')
+makedepends=('git')
+_commit='7bf22d97a19350fbf631aecb9742ee85b65c2be4'
+source=(
+ "$pkgname::git+https://github.com/KScl/opentyrian2000.git#commit=$_commit"
+ "$pkgname-assets.zip::https://camanis.net/tyrian/tyrian2000.zip"
+ 'update-paths.patch'
+)
+sha512sums=('SKIP'
+ 'b425b8524e408b128e249d2916597bd5bebd34ee418e3ddbe13306e1f86869eaba85db0ae5a5dbae4d477b7fec6e04e8fb292d516bba7aff96cf2795232dbfc1'
+ 'ae9567f32540ae18d345cc8070dc544b13141e7f41b002aeb12f63497ce58e0f5bdb7b017fd2719d0def5bc3533c2147bdf9cf7c5eb75809603a6b5c9cdba46b')
+b2sums=('SKIP'
+ '942ee68be24944e3d65612f323cd884e357341db42ee4ed5f487c7d1d650ab4bef98121dbdd321840bc3046f94c9491a6d777179821ba83ce0b4ad7573778aab'
+ '2d942ae0bcb609143f3684d922e39fa39066f3c9f6ce27b28376a5cf27f294c31dbeadd2cb495135051c3a22bd11bd489dbe4a73a183bb6f93ded9de7a83eb9d')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
+prepare() {
+ cd "$pkgname"
+
+ # patch Makefile & desktop file
+ patch -p1 -i ../update-paths.patch
+}
+
+build() {
+ make prefix=/usr all -C "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" prefix=/usr install
+
+ # desktop file & icons
+ install -vDm644 linux/opentyrian.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ for _x in 22 24 32 48 128; do
+ install -vDm644 "linux/icons/tyrian-$_x.png" \
+ "$pkgdir/usr/share/icons/hicolor/${_x}x${_x}/apps/$pkgname.png"
+ done
+
+ # assets
+ cd "$srcdir/tyrian2000"
+ install -vDm644 -t "$pkgdir/usr/share/$pkgname" \
+ *.dat *.lvl *.shp *.snd demo.* music.mus \
+ tyrend.anm tyrian.{cdt,hdt,pic} tshp2.pcx
+}
diff --git a/update-paths.patch b/update-paths.patch
new file mode 100644
index 000000000000..c1f31d0c3c2e
--- /dev/null
+++ b/update-paths.patch
@@ -0,0 +1,110 @@
+--- a/linux/man/opentyrian.6
++++ b/linux/man/opentyrian.6
+@@ -1,15 +1,15 @@
+-.TH opentyrian 6 "October 2009" "" "OpenTyrian Manual"
++.TH opentyrian2000 6 "October 2009" "" "OpenTyrian Manual"
+ .SH NAME
+-opentyrian \- an open-source port of the DOS game Tyrian
++opentyrian2000 \- an open-source port of the DOS game Tyrian2000
+ .SH SYNOPSIS
+-.B opentyrian
++.B opentyrian2000
+ .RI [ OPTIONS ]
+ .SH DESCRIPTION
+-Tyrian is an arcade-style vertical scrolling shooter. The story is set
++Tyrian2000 is an arcade-style vertical scrolling shooter. The story is set
+ in 20,031 where you play as Trent Hawkins, a skilled fighter-pilot employed
+ to fight MicroSol and save the galaxy.
+
+-Tyrian features a story mode, one- and two-player arcade modes, and networked
++Tyrian2000 features a story mode, one- and two-player arcade modes, and networked
+ multiplayer.
+ .SH "OPTIONS"
+ .PP
+@@ -39,11 +39,11 @@ and
+ \-\^\-net\-player\-number
+ to join game.
+
+-OpenTyrian uses UDP port
++OpenTyrian2000 uses UDP port
+ .B
+ 1333
+ for multiplayer, but in most cases players will not need to open any ports
+-because OpenTyrian makes use of UDP hole punching.
++because OpenTyrian2000 makes use of UDP hole punching.
+
+ .TP
+ .BI "\-\^\-net\-player\-name " "name"
+@@ -73,7 +73,7 @@ This program comes with ABSOLUTELY NO WARRANTY.
+ This is free software, and you are welcome to redistribute it
+ under certain conditions. See the file COPYING for details.
+
+-Data files bundled with this package come from Tyrian 2.1 data files
++Data files bundled with this package come from Tyrian 2000 data files
+ which have been released as freeware.
+
+ Daniel Cook released graphic files under very liberal
+
+--- a/linux/opentyrian.desktop
++++ b/linux/opentyrian2000.desktop
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+ Type=Application
+-Name=OpenTyrian
++Name=OpenTyrian2000
+ Comment=An arcade-style shoot 'em up
+-Icon=opentyrian
++Icon=opentyrian2000
+ Categories=Game;ArcadeGame;
+-TryExec=opentyrian
+-Exec=opentyrian
++TryExec=opentyrian2000
++Exec=opentyrian2000
+ Terminal=false
+
+
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@ ifneq ($(filter Msys Cygwin, $(shell uname -o)), )
+ TYRIAN_DIR = C:\\TYRIAN
+ else
+ PLATFORM := UNIX
+- TYRIAN_DIR = $(gamesdir)/tyrian
++ TYRIAN_DIR = $(gamesdir)/opentyrian2000
+ endif
+
+ WITH_NETWORK := true
+@@ -31,7 +31,7 @@ exec_prefix ?= $(prefix)
+ bindir ?= $(exec_prefix)/bin
+ datarootdir ?= $(prefix)/share
+ datadir ?= $(datarootdir)
+-docdir ?= $(datarootdir)/doc/opentyrian
++docdir ?= $(datarootdir)/doc/opentyrian2000
+ mandir ?= $(datarootdir)/man
+ man6dir ?= $(mandir)/man6
+ man6ext ?= .6
+@@ -42,7 +42,7 @@ gamesdir ?= $(datadir)/games
+
+ ###
+
+-TARGET := opentyrian
++TARGET := opentyrian2000
+
+ SRCS := $(wildcard src/*.c)
+ OBJS := $(SRCS:src/%.c=obj/%.o)
+@@ -115,13 +115,13 @@ installdirs :
+ install : $(TARGET) installdirs
+ $(INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(bindir)/
+ $(INSTALL_DATA) CREDITS NEWS README $(DESTDIR)$(docdir)/
+- $(INSTALL_DATA) linux/man/opentyrian.6 $(DESTDIR)$(man6dir)/opentyrian$(man6ext)
++ $(INSTALL_DATA) linux/man/opentyrian.6 $(DESTDIR)$(man6dir)/opentyrian2000$(man6ext)
+
+ .PHONY : uninstall
+ uninstall :
+ rm -f $(DESTDIR)$(bindir)/$(TARGET)
+ rm -f $(DESTDIR)$(docdir)/{CREDITS,NEWS,README}
+- rm -f $(DESTDIR)$(man6dir)/opentyrian$(man6ext)
++ rm -f $(DESTDIR)$(man6dir)/opentyrian2000$(man6ext)
+
+ .PHONY : clean
+ clean :