summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-02-01 22:19:28 +0000
committerGeorge Rawlinson2023-02-01 22:19:28 +0000
commit5f280e6553d6d49b716101348ef701f462762ed9 (patch)
tree91bbb9dc5af6dfabe8de1f1cfe3695e85c2b189f
parentf7a4b834165d1b656be86aed8bd1dcf33dd5f4fc (diff)
downloadaur-5f280e6553d6d49b716101348ef701f462762ed9.tar.gz
upgpkg: ottomatic 4.0.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD39
2 files changed, 30 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26631d64e243..fa7c7b48fa4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = ottomatic
pkgdesc = Save Earth from the clutches of The Giant Brain from Planet X
- pkgver = 4.0.0
+ pkgver = 4.0.1
pkgrel = 1
url = https://github.com/jorio/ottomatic
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
- makedepends = cmake
makedepends = git
+ makedepends = cmake
depends = sdl2
depends = glu
depends = hicolor-icon-theme
- source = ottomatic::git+https://github.com/jorio/ottomatic.git#tag=4.0.0
- source = git+https://github.com/jorio/Pomme.git
+ source = ottomatic::git+https://github.com/jorio/ottomatic.git#commit=197b5d45869124c29a8161d863f186f27cf4db0f
+ source = github.com-jorio-Pomme::git+https://github.com/jorio/Pomme
source = ottomatic.desktop
source = ottomatic.sh
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f2291d78db49..7c0099ed4ec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=ottomatic
-pkgver=4.0.0
+pkgver=4.0.1
pkgrel=1
-pkgdesc="Save Earth from the clutches of The Giant Brain from Planet X"
+pkgdesc='Save Earth from the clutches of The Giant Brain from Planet X'
arch=('x86_64')
-url="https://github.com/jorio/ottomatic"
+url='https://github.com/jorio/ottomatic'
license=('custom:CC-BY-NC-SA-4.0')
depends=('sdl2' 'glu' 'hicolor-icon-theme')
-makedepends=('cmake' 'git')
+makedepends=('git' 'cmake')
+_commit='197b5d45869124c29a8161d863f186f27cf4db0f'
source=(
- "$pkgname::git+$url.git#tag=$pkgver"
- 'git+https://github.com/jorio/Pomme.git'
+ "$pkgname::git+$url.git#commit=$_commit"
+ 'github.com-jorio-Pomme::git+https://github.com/jorio/Pomme'
"$pkgname.desktop"
"$pkgname.sh"
)
@@ -20,19 +21,31 @@ b2sums=('SKIP'
'b3452a8f143877ab688212ca9bfe4cdcd174667298fedd7cdcba4d7b4a1c49bf86bca0e456bcd2c64039cc322c540a583f9ff2e820e3ef38c0ef15984c348ae8'
'c8f7a247ba04156ee8b07ddcdcadcd75946f24347cbdc82363a02f8267a64db1f5b2a1326a1019d8d31c6697a7e5da409bdc52d6c28a0ecca7f9b8372933050c')
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
prepare() {
cd "$pkgname"
+
+ # setup git submodules
git submodule init
- git config submodule.Pomme.url ../Pomme
- git submodule update
- cmake -S . -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev
+ git config submodule.Pomme.url "$srcdir/github.com-jorio-Pomme"
+ git -c protocol.file.allow=always submodule update
}
build() {
cd "$pkgname"
+
+ cmake \
+ -S . \
+ -B build \
+ -D CMAKE_BUILD_TYPE=None \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -W no-dev
+
cmake --build build
}
@@ -48,7 +61,7 @@ package() {
# desktop file & icon
install -vDm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
- install -vDm644 packaging/ottomatic-desktopicon.png \
+ install -vDm644 packaging/io.jor.ottomatic.png \
"$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
# documentation