summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-08-21 22:01:23 +0000
committerGeorge Rawlinson2021-08-21 22:01:23 +0000
commitf7a4b834165d1b656be86aed8bd1dcf33dd5f4fc (patch)
tree25ab8d76cfb558c81eabd23a2f4b32fea178cc4e
downloadaur-f7a4b834165d1b656be86aed8bd1dcf33dd5f4fc.tar.gz
addpkg: ottomatic 4.0.0-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD63
-rw-r--r--ottomatic.desktop11
-rwxr-xr-xottomatic.sh4
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26631d64e243
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ottomatic
+ pkgdesc = Save Earth from the clutches of The Giant Brain from Planet X
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/jorio/ottomatic
+ arch = x86_64
+ license = custom:CC-BY-NC-SA-4.0
+ makedepends = cmake
+ makedepends = git
+ depends = sdl2
+ depends = glu
+ depends = hicolor-icon-theme
+ source = ottomatic::git+https://github.com/jorio/ottomatic.git#tag=4.0.0
+ source = git+https://github.com/jorio/Pomme.git
+ source = ottomatic.desktop
+ source = ottomatic.sh
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = b3452a8f143877ab688212ca9bfe4cdcd174667298fedd7cdcba4d7b4a1c49bf86bca0e456bcd2c64039cc322c540a583f9ff2e820e3ef38c0ef15984c348ae8
+ b2sums = c8f7a247ba04156ee8b07ddcdcadcd75946f24347cbdc82363a02f8267a64db1f5b2a1326a1019d8d31c6697a7e5da409bdc52d6c28a0ecca7f9b8372933050c
+
+pkgname = ottomatic
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2291d78db49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+
+pkgname=ottomatic
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Save Earth from the clutches of The Giant Brain from Planet X"
+arch=('x86_64')
+url="https://github.com/jorio/ottomatic"
+license=('custom:CC-BY-NC-SA-4.0')
+depends=('sdl2' 'glu' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+source=(
+ "$pkgname::git+$url.git#tag=$pkgver"
+ 'git+https://github.com/jorio/Pomme.git'
+ "$pkgname.desktop"
+ "$pkgname.sh"
+)
+b2sums=('SKIP'
+ 'SKIP'
+ 'b3452a8f143877ab688212ca9bfe4cdcd174667298fedd7cdcba4d7b4a1c49bf86bca0e456bcd2c64039cc322c540a583f9ff2e820e3ef38c0ef15984c348ae8'
+ 'c8f7a247ba04156ee8b07ddcdcadcd75946f24347cbdc82363a02f8267a64db1f5b2a1326a1019d8d31c6697a7e5da409bdc52d6c28a0ecca7f9b8372933050c')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.Pomme.url ../Pomme
+ git submodule update
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+}
+
+build() {
+ cd "$pkgname"
+ cmake --build build
+}
+
+package() {
+ cd "$pkgname"
+
+ # move binary & assets
+ install -vd "$pkgdir/usr/lib/$pkgname"
+ mv -v build/{Data,OttoMatic} "$pkgdir/usr/lib/$pkgname"
+
+ # wrapper script for $PATH execution
+ install -vDm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # desktop file & icon
+ install -vDm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
+ install -vDm644 packaging/ottomatic-desktopicon.png \
+ "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
+
+ # documentation
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
+ rm -vf "$pkgdir/usr/share/doc/$pkgname/LICENSE.md"
+ cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
+ sed -e "s/@PROJECT_VERSION@/$pkgver/" packaging/ReadMe.txt.in \
+ > "$pkgdir/usr/share/doc/$pkgname/README"
+
+ # license
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
+}
diff --git a/ottomatic.desktop b/ottomatic.desktop
new file mode 100644
index 000000000000..9e3854dbaef6
--- /dev/null
+++ b/ottomatic.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Otto Matic
+Comment=Save Earth from the clutches of The Giant Brain from Planet X
+Icon=ottomatic
+Exec=/usr/lib/ottomatic/OttoMatic
+Path=/usr/lib/ottomatic
+Terminal=false
+Categories=Game;
+Encoding=UTF-8
diff --git a/ottomatic.sh b/ottomatic.sh
new file mode 100755
index 000000000000..596ccd0ee4b1
--- /dev/null
+++ b/ottomatic.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+
+cd /usr/lib/ottomatic
+exec /usr/lib/ottomatic/OttoMatic