summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Torres2015-08-27 14:00:04 +0200
committerJavier Torres2015-08-27 14:00:04 +0200
commita696877c716fe9229af34926a91e34216cac80fd (patch)
treeb09006d9e9b4bdab39d226e6a7fe7931e6c9a105
downloadaur-a696877c716fe9229af34926a91e34216cac80fd.tar.gz
Import package from old AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--pear-http-request2.install7
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cde86df3852
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pear-http-request2
+ pkgdesc = Provides an easy way to perform HTTP requests.
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://pear.php.net/package/HTTP_Request2
+ install = pear-http-request2.install
+ arch = any
+ license = BSD3
+ makedepends = php-pear>=1.9.2
+ depends = php>=5.2.0
+ depends = pear-net-url2>=2.0.0
+ noextract = HTTP_Request2-2.2.1.tgz
+ options = !strip
+ source = http://download.pear.php.net/package/HTTP_Request2-2.2.1.tgz
+ source = pear-http-request2.install
+ md5sums = 36c8406b0d95bbdec54ad0fdafa73d00
+ md5sums = bd7b8d4499b021db6d181faf3893c76b
+
+pkgname = pear-http-request2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a9a00ab0782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Javier Torres <javitonino [at] gmail [dot] com>
+# Contributor: max-k <max-k AT post DOT com>
+
+pkgname=pear-http-request2
+_pkgname=HTTP_Request2
+pkgver=2.2.1
+pkgrel=1
+pkgdesc='Provides an easy way to perform HTTP requests.'
+arch=('any')
+url="http://pear.php.net/package/${_pkgname}"
+license=('BSD3')
+depends=('php>=5.2.0' 'pear-net-url2>=2.0.0')
+makedepends=('php-pear>=1.9.2')
+options=('!strip')
+install="${pkgname}.install"
+noextract=(${_pkgname}-${pkgver}.tgz)
+source=(http://download.pear.php.net/package/${_pkgname}-${pkgver}.tgz
+ pear-http-request2.install)
+md5sums=('36c8406b0d95bbdec54ad0fdafa73d00'
+ 'bd7b8d4499b021db6d181faf3893c76b')
+
+package() {
+ cd ${srcdir}
+ local _PEARDIR="${pkgdir}/usr/share/pear"
+ local _PEAROPTS="-D php_dir=${_PEARDIR} -D doc_dir=${_PEARDIR}/doc"
+ local _PEAROPTS="${_PEAROPTS} -D test_dir=${_PEARDIR}/test"
+ local _PEAROPTS="${_PEAROPTS} -D data_dir=${_PEARDIR}/data"
+ pear ${_PEAROPTS} install -O -n ${_pkgname}-${pkgver}.tgz
+ rm -r ${_PEARDIR}/{.channels,.depdb*,.filemap,.lock,.registry/.chan*}
+}
+
diff --git a/pear-http-request2.install b/pear-http-request2.install
new file mode 100644
index 000000000000..cd9a9e2b4c34
--- /dev/null
+++ b/pear-http-request2.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo
+ echo "Following PHP extensions are optional :"
+ echo " * curl"
+ echo " * openssl"
+ echo
+}