summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXorg2022-05-10 18:54:39 +0200
committerXorg2022-05-10 18:54:39 +0200
commit0e3f8045173d208b9deab1112496eff585cc4079 (patch)
treeeb3309de30a338c5ddc19f3212150aa33312b370
parentee3632fa4c1ef066e990ef5bd1a7decf1da5b02c (diff)
downloadaur-0e3f8045173d208b9deab1112496eff585cc4079.tar.gz
Rewrite package for v4.0.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD85
-rw-r--r--install14
3 files changed, 55 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5217d2b94aea..85f85f95f9d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = procps-ng-git
pkgdesc = Utilities for monitoring your system and its processes
- pkgver = 3.3.11
- pkgrel = 42
- url = http://gitlab.com/procps-ng/procps/
- install = install
+ pkgver = 4.0.0.r54.g6e78355d
+ pkgrel = 1
+ url = https://gitlab.com/procps-ng/procps
arch = i686
arch = x86_64
- groups = base
- license = GPL
- license = LGPL
+ license = GPL2
+ license = LGPL2
makedepends = git
makedepends = m4
makedepends = autoconf
makedepends = libtool
+ makedepends = systemd
+ depends = glibc
depends = ncurses
- depends = systemd
+ depends = libncursesw.so
+ depends = systemd-libs
provides = procps
- provides = sysvinit-tools
provides = procps-ng
+ provides = sysvinit-tools
+ provides = libproc-2.so
conflicts = procps
- conflicts = sysvinit-tools
conflicts = procps-ng
+ conflicts = sysvinit-tools
replaces = procps
+ replaces = procps-ng
replaces = sysvinit-tools
+ options = !emptydirs
+ source = git+https://gitlab.com/procps-ng/procps.git
+ sha512sums = SKIP
pkgname = procps-ng-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 25b2f623a7d6..c68890101383 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,53 @@
-# $Id$
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: X0rg
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Eric BĂ©langer <eric@archlinux.org>
-_pkgname=procps-ng
+_realname=procps
pkgname=procps-ng-git
-pkgver=3.3.11
-pkgrel=42
+pkgver=4.0.0.r54.g6e78355d
+pkgrel=1
pkgdesc='Utilities for monitoring your system and its processes'
-url='http://gitlab.com/procps-ng/procps/'
-license=('GPL' 'LGPL')
+url='https://gitlab.com/procps-ng/procps'
+license=('GPL2' 'LGPL2')
arch=('i686' 'x86_64')
-depends=('ncurses' 'systemd')
-makedepends=('git' 'm4' 'autoconf' 'libtool')
-source=()
-sha256sums=()
-_gitroot="https://gitlab.com/procps-ng/procps.git"
-_gitname="procps-ng"
-
-groups=('base')
-
-conflicts=('procps' 'sysvinit-tools' 'procps-ng')
-provides=('procps' 'sysvinit-tools' 'procps-ng')
-replaces=('procps' 'sysvinit-tools')
-
-install=install
+depends=('glibc' 'ncurses' 'libncursesw.so' 'systemd-libs')
+makedepends=('git' 'm4' 'autoconf' 'libtool' 'systemd')
+conflicts=('procps' 'procps-ng' 'sysvinit-tools')
+provides=('procps' 'procps-ng' 'sysvinit-tools' 'libproc-2.so')
+replaces=('procps' 'procps-ng' 'sysvinit-tools')
+options=('!emptydirs')
+source=("git+https://gitlab.com/procps-ng/procps.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_realname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
-cd ${srcdir}
- msg "Downloading from upstream git ...."
-
- if [ -d "${srcdir}/${_gitname}" ] ; then
- cd ${_gitname} && git pull --rebase
- else
- git clone ${_gitroot} ${_gitname}
- cd ${_gitname}
- fi
+ cd "$_realname"
+ sed 's:<ncursesw/:<:g' -i watch.c
}
build() {
- cd "${srcdir}/${_gitname}"
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --exec-prefix=/ \
- --sysconfdir=/etc \
- --libdir=/usr/lib \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-kill \
-
- make
+ cd "$_realname"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/ \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --enable-watch8bit \
+ --with-systemd \
+ --disable-modern-top \
+ --disable-kill
+
+ make
}
package() {
- cd "${srcdir}/${_gitname}"
- msg PKGDIR=${pkgdir}
- make DESTDIR="${pkgdir}" install
-
+ cd "$_realname"
+ make DESTDIR="$pkgdir" install
}
diff --git a/install b/install
deleted file mode 100644
index ce2088d2b800..000000000000
--- a/install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_upgrade() {
- if [[ $(vercmp $2 3.3.8-3) = -1 ]]; then
- cat <<EOF
-
-==> The file /etc/sysctl.conf has been removed from this
-==> package, as all its settings are now kernel defaults.
-
-==> If you had customized it, you need to rename it as
-==> /etc/sysctl.d/99-sysctl.conf since from version 207 on
-==> systemd only applies settings from /etc/sysctl.d/* .
-
-EOF
- fi
-}