summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWhyme Lyu2019-11-15 21:58:26 +0800
committerWhyme Lyu2019-11-15 21:58:26 +0800
commit313b9c4e20bdda292c7df5e27e9a30c4807c56d4 (patch)
tree5569699f2fc3c73034ef58217eea3bf86afc669a
parent0d00cd24af217193184993c1ee2af082dcfed1a2 (diff)
downloadaur-313b9c4e20bdda292c7df5e27e9a30c4807c56d4.tar.gz
python37: don't bother check()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 2 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adbf08eb712b..cae037ee6caa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python37
pkgdesc = Major release 3.7 of the Python high-level programming language
pkgver = 3.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.python.org/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index a9b22a67345e..5e3faea5e005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=python37
pkgver=3.7.5
-pkgrel=1
+pkgrel=2
_pybasever=${pkgver%.*}
_pymajver=3
pkgdesc="Major release 3.7 of the Python high-level programming language"
@@ -83,27 +83,6 @@ build() {
LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
}
-check() {
- # test_gdb is expected to fail with LTO
- # test_idle, test_tk, test_ttk_guionly segfaults since 3.6.5
-
- # https://bugs.python.org/issue34022
- # test_cmd_line_script, test_compileall, test_importlib,
- # test_multiprocessing_main_handling, test_py_compile, test_runpy
-
- cd Python-${pkgver}
-
- # Obtain next free server number for xvfb-run; this even works in a chroot environment.
- export servernum=99
- while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
-
- LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
- LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum" \
- "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly \
- -x test_cmd_line_script -x test_compileall -x test_importlib -x test_multiprocessing_main_handling -x test_py_compile -x test_runpy \
- -x test_httplib
-}
-
package() {
cd Python-${pkgver}