summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWhyme Lyu2020-03-13 13:10:46 +0800
committerWhyme Lyu2020-03-13 13:10:46 +0800
commit55b8153fc7ab725b2502985d9b0188caf681efb3 (patch)
tree2d0e4bbd1e40c5b43ca75421e61991802c14edee
parente160977ab0f33e2be2883db402ba1ab885164f65 (diff)
downloadaur-55b8153fc7ab725b2502985d9b0188caf681efb3.tar.gz
Remove outdated patch 0001
-rw-r--r--.SRCINFO4
-rw-r--r--0001-compileall-Fix-ddir-when-recursing.patch57
-rw-r--r--PKGBUILD7
3 files changed, 2 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b8ecd39b500..30665636071d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python37
pkgdesc = Major release 3.7 of the Python high-level programming language
pkgver = 3.7.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.python.org/
arch = x86_64
license = custom
@@ -27,13 +27,11 @@ pkgbase = python37
source = https://www.python.org/ftp/python/3.7.7/Python-3.7.7.tar.xz
source = https://www.python.org/ftp/python/3.7.7/Python-3.7.7.tar.xz.asc
source = dont-make-libpython-readonly.patch
- source = 0001-compileall-Fix-ddir-when-recursing.patch
source = 0002-smaller-pgo-test-suite.patch
validpgpkeys = 0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D
sha512sums = ddc838a7b0c442c2e465616f20231f2b703ed6b69ed2dc17858aac8760814fdf7cff43d350d359300e47b6bb1f0bd38c31126b855e423a3a65ed06a8fa16d136
sha512sums = SKIP
sha512sums = 2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4
- sha512sums = ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff
sha512sums = 10db463924402b6f1d9631424397495e8be0419bc7f9ca6cd7325216433b2dfe512b6f6669626ff05a8e05a6013613660abee59fcb86e5483558b014687bfaa1
pkgname = python37
diff --git a/0001-compileall-Fix-ddir-when-recursing.patch b/0001-compileall-Fix-ddir-when-recursing.patch
deleted file mode 100644
index 91ebc71f6a22..000000000000
--- a/0001-compileall-Fix-ddir-when-recursing.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 84fdbc156ed424d030686de350fbfc6c3593263f Mon Sep 17 00:00:00 2001
-Message-Id: <84fdbc156ed424d030686de350fbfc6c3593263f.1537028533.git.jan.steffens@gmail.com>
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Sat, 15 Sep 2018 18:22:06 +0200
-Subject: [PATCH] compileall: Fix ddir when recursing
-
----
- Lib/compileall.py | 14 +++++++++-----
- 1 file changed, 9 insertions(+), 5 deletions(-)
-
-diff --git a/Lib/compileall.py b/Lib/compileall.py
-index 72592126d7..70e246fd96 100644
---- a/Lib/compileall.py
-+++ b/Lib/compileall.py
-@@ -45,12 +45,16 @@ def _walk_dir(dir, ddir=None, maxlevels=10, quiet=0):
- else:
- dfile = None
- if not os.path.isdir(fullname):
-- yield fullname
-+ yield fullname, ddir
- elif (maxlevels > 0 and name != os.curdir and name != os.pardir and
- os.path.isdir(fullname) and not os.path.islink(fullname)):
- yield from _walk_dir(fullname, ddir=dfile,
- maxlevels=maxlevels - 1, quiet=quiet)
-
-+def _compile_one(file_ddir, *args, **kwargs):
-+ file, ddir = file_ddir
-+ return compile_file(file, ddir, *args, **kwargs)
-+
- def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
- quiet=0, legacy=False, optimize=-1, workers=1,
- invalidation_mode=py_compile.PycInvalidationMode.TIMESTAMP):
-@@ -79,17 +83,17 @@ def compile_dir(dir, maxlevels=10, ddir=None, force=False, rx=None,
- if workers is not None and workers != 1 and ProcessPoolExecutor is not None:
- workers = workers or None
- with ProcessPoolExecutor(max_workers=workers) as executor:
-- results = executor.map(partial(compile_file,
-- ddir=ddir, force=force,
-+ results = executor.map(partial(_compile_one,
-+ force=force,
- rx=rx, quiet=quiet,
- legacy=legacy,
- optimize=optimize,
- invalidation_mode=invalidation_mode),
- files)
- success = min(results, default=True)
- else:
-- for file in files:
-- if not compile_file(file, ddir, force, rx, quiet,
-+ for file_ddir in files:
-+ if not _compile_one(file_ddir, force, rx, quiet,
- legacy, optimize, invalidation_mode):
- success = False
- return success
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 45e219d8bfb4..35f296ccb5a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=python37
pkgver=3.7.7
-pkgrel=1
+pkgrel=2
_pybasever=${pkgver%.*}
_pymajver=3
pkgdesc="Major release 3.7 of the Python high-level programming language"
@@ -24,13 +24,11 @@ optdepends=('sqlite'
'tk: for tkinter')
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
dont-make-libpython-readonly.patch
- 0001-compileall-Fix-ddir-when-recursing.patch
0002-smaller-pgo-test-suite.patch
)
sha512sums=('ddc838a7b0c442c2e465616f20231f2b703ed6b69ed2dc17858aac8760814fdf7cff43d350d359300e47b6bb1f0bd38c31126b855e423a3a65ed06a8fa16d136'
'SKIP'
'2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4'
- 'ebd04c3b6d41321b1f0d439d356e0ce463760db55dc64109854c70d017cf56608aa19de9fc4a21bf840795ff202b4703444f9af8074b661780798c17e03089ff'
'10db463924402b6f1d9631424397495e8be0419bc7f9ca6cd7325216433b2dfe512b6f6669626ff05a8e05a6013613660abee59fcb86e5483558b014687bfaa1')
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D') # Ned Deily (Python release signing key) <nad@python.org>
@@ -40,9 +38,6 @@ prepare() {
# FS#45809
patch -p1 -i ../dont-make-libpython-readonly.patch
- # FS#59997
- patch -p1 -i ../0001-compileall-Fix-ddir-when-recursing.patch
-
# Backport https://bugs.python.org/issue36044 to 3.7
patch -p1 -i ../0002-smaller-pgo-test-suite.patch