summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoan Blanc2020-09-02 21:40:33 +0200
committerYoan Blanc2020-09-02 21:40:33 +0200
commitfc747373f5f3abc3c988d815187415f959dad8ff (patch)
tree64a9162dd9154464f9f9a502e80601f01a5f26ac
parentaa50417d2afe809a935595eaf767c33ce512e934 (diff)
downloadaur-fc747373f5f3abc3c988d815187415f959dad8ff.tar.gz
Upgrade python37 to 3.7.9
Signed-off-by: Yoan Blanc <yoan@dosimple.ch>
-rw-r--r--.SRCINFO12
-rw-r--r--0003-enable-building-with-libmpdec.patch30
-rw-r--r--PKGBUILD17
3 files changed, 49 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae4ac874129..60541026d292 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python37
pkgdesc = Major release 3.7 of the Python high-level programming language
- pkgver = 3.7.8
- pkgrel = 2
+ pkgver = 3.7.9
+ pkgrel = 1
url = https://www.python.org/
arch = x86_64
license = custom
@@ -24,15 +24,17 @@ pkgbase = python37
optdepends = mpdecimal: for decimal
optdepends = xz: for lzma
optdepends = tk: for tkinter
- source = https://www.python.org/ftp/python/3.7.8/Python-3.7.8.tar.xz
- source = https://www.python.org/ftp/python/3.7.8/Python-3.7.8.tar.xz.asc
+ source = https://www.python.org/ftp/python/3.7.9/Python-3.7.9.tar.xz
+ source = https://www.python.org/ftp/python/3.7.9/Python-3.7.9.tar.xz.asc
source = dont-make-libpython-readonly.patch
source = 0002-smaller-pgo-test-suite.patch
+ source = 0003-enable-building-with-libmpdec.patch
validpgpkeys = 0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D
- sha512sums = d2ba299e3cf8ed0f8fed9317f42bcd8d9af7e0e6175939b4be1be289c1658418bed17899e2608d762ffb15575021956cf6bf2054d7863c04b3bd7642f5b8c7ea
+ sha512sums = e4217b25529b5336e43b63d17f3758a8177a58184564cf02bd92a312f58dba9e096485c9e3cb3544f966e847ea15b3ab30ed065d28a6ca52a6d7e0faddf7d9f9
sha512sums = SKIP
sha512sums = 2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4
sha512sums = 10db463924402b6f1d9631424397495e8be0419bc7f9ca6cd7325216433b2dfe512b6f6669626ff05a8e05a6013613660abee59fcb86e5483558b014687bfaa1
+ sha512sums = 991540591e2e024d02f2a6f85a98b43ee0e270d223c66572f2d700b32d89c8afa4faa61d45d41998e108c7b1633da20f7f43b37b2d846364431ebdab921dff17
pkgname = python37
diff --git a/0003-enable-building-with-libmpdec.patch b/0003-enable-building-with-libmpdec.patch
new file mode 100644
index 000000000000..fd85ec297b17
--- /dev/null
+++ b/0003-enable-building-with-libmpdec.patch
@@ -0,0 +1,30 @@
+From 16eea45fbd3b7c3d1b222b7eb7a5d7ee427f70bd Mon Sep 17 00:00:00 2001
+From: Felix Yan <felixonmars@archlinux.org>
+Date: Thu, 16 Jul 2020 04:22:23 +0800
+Subject: [PATCH] [3.8] bpo-41302: Support system libmpdec 2.5 for Python 3.8
+ (GH-21488)
+
+Define UNUSED only when mpdecimal.h doesn't define it. This would support
+building with system libmpdec 2.5 while retaining compatibility with system
+libmpdec 2.4 or the vendored copy.
+
+Tested to build fine with either system libmpdec or the vendored one.
+---
+diff --git a/Modules/_decimal/_decimal.c b/Modules/_decimal/_decimal.c
+index df7c6e254bcf2..eb1f1a01feeca 100644
+--- a/Modules/_decimal/_decimal.c
++++ b/Modules/_decimal/_decimal.c
+@@ -58,6 +58,13 @@
+
+ #define BOUNDS_CHECK(x, MIN, MAX) x = (x < MIN || MAX < x) ? MAX : x
+
++#ifndef UNUSED
++#if defined(__GNUC__) && !defined(__INTEL_COMPILER)
++ #define UNUSED __attribute__((unused))
++#else
++ #define UNUSED
++#endif
++#endif
+
+ /* _Py_DEC_MINALLOC >= MPD_MINALLOC */
+ #define _Py_DEC_MINALLOC 4
diff --git a/PKGBUILD b/PKGBUILD
index 20bd74733f1c..46551702dfc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Whyme Lyu <callme5long@gmail.com>
+# Maintainer: Yoan Blanc <yoan@dosimple.ch>
+# Contributor: Whyme Lyu <callme5long@gmail.com>
# Contributor: Carlo De Pieri <depieri.carlo@gmail.com>
# Contributor: Tobias Kunze <r@rixx.de>
# Contributor: Angel Velasquez <angvp@archlinux.org>
@@ -8,8 +9,8 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python37
-pkgver=3.7.8
-pkgrel=2
+pkgver=3.7.9
+pkgrel=1
_pybasever=${pkgver%.*}
_pymajver=3
pkgdesc="Major release 3.7 of the Python high-level programming language"
@@ -25,11 +26,14 @@ optdepends=('sqlite'
source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
dont-make-libpython-readonly.patch
0002-smaller-pgo-test-suite.patch
+ 0003-enable-building-with-libmpdec.patch
)
-sha512sums=('d2ba299e3cf8ed0f8fed9317f42bcd8d9af7e0e6175939b4be1be289c1658418bed17899e2608d762ffb15575021956cf6bf2054d7863c04b3bd7642f5b8c7ea'
+sha512sums=('e4217b25529b5336e43b63d17f3758a8177a58184564cf02bd92a312f58dba9e096485c9e3cb3544f966e847ea15b3ab30ed065d28a6ca52a6d7e0faddf7d9f9'
'SKIP'
'2ef96708d5b13ae2a3d2cc62c87b4780e60ecfce914e190564492def3a11d5e56977659f41c7f9d12266e58050c766bce4e2b5d50b708eb792794fa8357920c4'
- '10db463924402b6f1d9631424397495e8be0419bc7f9ca6cd7325216433b2dfe512b6f6669626ff05a8e05a6013613660abee59fcb86e5483558b014687bfaa1')
+ '10db463924402b6f1d9631424397495e8be0419bc7f9ca6cd7325216433b2dfe512b6f6669626ff05a8e05a6013613660abee59fcb86e5483558b014687bfaa1'
+ '991540591e2e024d02f2a6f85a98b43ee0e270d223c66572f2d700b32d89c8afa4faa61d45d41998e108c7b1633da20f7f43b37b2d846364431ebdab921dff17'
+ )
validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D') # Ned Deily (Python release signing key) <nad@python.org>
prepare() {
@@ -41,6 +45,9 @@ prepare() {
# Backport https://bugs.python.org/issue36044 to 3.7
patch -p1 -i ../0002-smaller-pgo-test-suite.patch
+ # Backport https://bugs.python.org/issue41302 to 3.7
+ patch -p1 -i ../0003-enable-building-with-libmpdec.patch
+
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py