summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2023-07-16 08:23:07 +0200
committerNicolas Iooss2023-07-16 08:23:07 +0200
commit219fde13d351dad870d3ea6cef74b8c1016b2480 (patch)
tree580b51603d58fdb08eef6471e26b64625590ecf9
parent8c5ea9c26bc7aa185ad7abd2f27738c6251da6cf (diff)
downloadaur-219fde13d351dad870d3ea6cef74b8c1016b2480.tar.gz
systemd-selinux 253.6-2 update
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32be684809c5..1eb0d14b8577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = systemd-selinux
- pkgver = 253.5
+ pkgver = 253.6
pkgrel = 2
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -50,7 +50,7 @@ pkgbase = systemd-selinux
makedepends = gnutls
makedepends = libselinux
options = strip
- source = git+https://github.com/systemd/systemd-stable#tag=c2b13f4d9f08d7f4ec113845195ea24bc871e7c0?signed
+ source = git+https://github.com/systemd/systemd-stable#tag=c017ed867787d09484ba7de75a8f025820596955?signed
source = git+https://github.com/systemd/systemd#tag=v253?signed
source = 0001-Use-Arch-Linux-device-access-groups.patch
source = initcpio-hook-udev
@@ -146,9 +146,9 @@ pkgname = systemd-selinux
optdepends = libp11-kit: support PKCS#11
optdepends = tpm2-tss: unlocking LUKS2 volumes with TPM2
provides = nss-myhostname
- provides = systemd-tools=253.5
- provides = udev=253.5
- provides = systemd=253.5-2
+ provides = systemd-tools=253.6
+ provides = udev=253.6
+ provides = systemd=253.6-2
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -186,7 +186,7 @@ pkgname = systemd-libs-selinux
provides = libsystemd.so
provides = libudev.so
provides = libsystemd-selinux
- provides = systemd-libs=253.5-2
+ provides = systemd-libs=253.6-2
conflicts = libsystemd
conflicts = libsystemd-selinux
conflicts = systemd-libs
@@ -198,16 +198,16 @@ pkgname = systemd-resolvconf-selinux
depends = systemd-selinux
provides = openresolv
provides = resolvconf
- provides = systemd-resolvconf=253.5-2
+ provides = systemd-resolvconf=253.6-2
conflicts = openresolv
- conflicts = systemd-resolvconf=253.5-2
+ conflicts = systemd-resolvconf=253.6-2
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=253.5-2
- provides = selinux-systemd-sysvcompat=253.5-2
+ provides = systemd-sysvcompat=253.6-2
+ provides = selinux-systemd-sysvcompat=253.6-2
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
@@ -221,4 +221,4 @@ pkgname = systemd-ukify-selinux
optdepends = python-pillow: Show the size of splash image
optdepends = sbsigntools: Sign the embedded kernel
provides = ukify
- provides = systemd-ukify=253.5-2
+ provides = systemd-ukify=253.6-2
diff --git a/PKGBUILD b/PKGBUILD
index 2a6eb45116fe..1f8f1713bd1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ pkgname=('systemd-selinux'
'systemd-resolvconf-selinux'
'systemd-sysvcompat-selinux'
'systemd-ukify-selinux')
-_tag='c2b13f4d9f08d7f4ec113845195ea24bc871e7c0' # git rev-parse v${_tag_name}
-_tag_name=253.5
+_tag='c017ed867787d09484ba7de75a8f025820596955' # git rev-parse v${_tag_name}
+_tag_name=253.6
pkgver="${_tag_name/-/}"
pkgrel=2
arch=('x86_64' 'aarch64')
@@ -73,8 +73,6 @@ sha512sums=('SKIP'
'825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97')
_backports=(
- # Revert "core/service: when resetting PID also reset known flag"
- '996b00ede87d6a870332e63974a7d4def3c2f1b0'
)
_reverts=(
@@ -86,18 +84,16 @@ prepare() {
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
- local _c
+ local _c _l
for _c in "${_backports[@]}"; do
- if [[ $_c == *..* ]]; then
- git log --oneline --reverse "${_c}"
- else
- git log --oneline -1 "${_c}"
- fi
- git cherry-pick -n -m1 "${_c}"
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git cherry-pick --mainline 1 --no-commit "${_c}"
done
for _c in "${_reverts[@]}"; do
- git log --oneline -1 "${_c}"
- git revert -n "${_c}"
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git revert --mainline 1 --no-commit "${_c}"
done
# Replace cdrom/dialout/tape groups with optical/uucp/storage