summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2022-11-02 23:28:55 +0100
committerNicolas Iooss2022-11-02 23:28:55 +0100
commit926716245139ea17035a3ab4532731b7608df53e (patch)
tree51f86fdee4a5fb17e0e35b50ea1551f903a295c2
parentd0150edbffc303cbe41e936610104e0f95bdd6aa (diff)
downloadaur-926716245139ea17035a3ab4532731b7608df53e.tar.gz
systemd-selinux 251.7-1 update
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d88d62636da0..ae9f73033560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = systemd-selinux
- pkgver = 251.4
+ pkgver = 251.7
pkgrel = 1
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -44,7 +44,7 @@ pkgbase = systemd-selinux
makedepends = rsync
makedepends = libselinux
options = strip
- source = git+https://github.com/systemd/systemd-stable#tag=46cf27a20eb6fb676ac987533415d499b77dd0af?signed
+ source = git+https://github.com/systemd/systemd-stable#tag=7442d25a54b6dd494299b3a932b28953f4e67b21?signed
source = git+https://github.com/systemd/systemd#tag=v251?signed
source = 0001-Use-Arch-Linux-device-access-groups.patch
source = initcpio-hook-udev
@@ -135,9 +135,9 @@ pkgname = systemd-selinux
optdepends = libfido2: unlocking LUKS2 volumes with FIDO2 token
optdepends = tpm2-tss: unlocking LUKS2 volumes with TPM2
provides = nss-myhostname
- provides = systemd-tools=251.4
- provides = udev=251.4
- provides = systemd=251.4-1
+ provides = systemd-tools=251.7
+ provides = udev=251.7
+ provides = systemd=251.7-1
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -175,7 +175,7 @@ pkgname = systemd-libs-selinux
provides = libsystemd.so
provides = libudev.so
provides = libsystemd-selinux
- provides = systemd-libs=251.4-1
+ provides = systemd-libs=251.7-1
conflicts = libsystemd
conflicts = libsystemd-selinux
conflicts = systemd-libs
@@ -187,16 +187,16 @@ pkgname = systemd-resolvconf-selinux
depends = systemd-selinux
provides = openresolv
provides = resolvconf
- provides = systemd-resolvconf=251.4-1
+ provides = systemd-resolvconf=251.7-1
conflicts = openresolv
- conflicts = systemd-resolvconf=251.4-1
+ conflicts = systemd-resolvconf=251.7-1
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=251.4-1
- provides = selinux-systemd-sysvcompat=251.4-1
+ provides = systemd-sysvcompat=251.7-1
+ provides = selinux-systemd-sysvcompat=251.7-1
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index 1ae706fb08e1..b00b98251d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,4 @@
# Maintainer: Christian Hesse <mail@eworm.de>
-# Maintainer: Dave Reisner <dreisner@archlinux.org>
-# Maintainer: Tom Gundersen <teg@jklm.no>
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
@@ -10,8 +8,8 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'systemd-libs-selinux' 'systemd-resolvconf-selinux' 'systemd-sysvcompat-selinux')
-_tag='46cf27a20eb6fb676ac987533415d499b77dd0af' # git rev-parse v${_tag_name}
-_tag_name=251.4
+_tag='7442d25a54b6dd494299b3a932b28953f4e67b21' # git rev-parse v${_tag_name}
+_tag_name=251.7
pkgver="${_tag_name/-/}"
pkgrel=1
arch=('x86_64' 'aarch64')
@@ -70,6 +68,8 @@ sha512sums=('SKIP'
'825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97')
_backports=(
+ # meson: Fix build with --optimization=plain
+ '7aa4762ce274a1c9a59902b972fa4fdee1b22715'
)
_reverts=(
@@ -97,11 +97,6 @@ prepare() {
# Replace cdrom/dialout/tape groups with optical/uucp/storage
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
-
- # Dirty fix for https://github.com/systemd/systemd/issues/24323
- # while waiting for meson to fix the underlying issue introduced in
- # https://github.com/mesonbuild/meson/pull/10593
- sed -i -e "s/^if get_option('optimization') != '0'/if get_option('optimization') != '0' and get_option('optimization') != 'plain'/" src/boot/efi/meson.build
}
build() {
@@ -206,7 +201,7 @@ package_systemd-selinux() {
etc/udev/udev.conf)
install=systemd.install
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote