summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Edson2021-10-14 05:48:25 -0700
committerJason Edson2021-10-14 05:48:25 -0700
commit6a469943b2db7803796fdb26306c681fb4f6fce1 (patch)
tree2a9a05559b2ac9ae1238f0c657e9816ea87aecde
parent6d99acad15802edad4caab8667ddaab98806a8de (diff)
downloadaur-6a469943b2db7803796fdb26306c681fb4f6fce1.tar.gz
Add libvte-2.91.so to provides
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD50
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 888a0efc4d21..ceaba9859bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
pkgver = 0.66.0
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Terminal/VTE
arch = i686
arch = x86_64
@@ -31,6 +31,7 @@ pkgname = vte3-notification
depends = gnutls
depends = vte-notification-common
provides = vte3=0.66.0
+ provides = libvte-2.91.so
conflicts = vte3
pkgname = vte-notification-common
diff --git a/PKGBUILD b/PKGBUILD
index 95334b19754a..c785c9e1ad9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,26 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Jason Edson <jaysonedson@gmail.com>
-pkgbase='vte3-notification'
-pkgname=("${pkgbase}" 'vte-notification-common')
+pkgbase=vte3-notification
+pkgname=(${pkgbase} vte-notification-common)
pkgver=0.66.0
-pkgrel=1
+pkgrel=2
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url='https://wiki.gnome.org/Apps/Terminal/VTE'
-license=('LGPL')
-depends=('fribidi'
- 'gnutls'
- 'gtk3'
- 'pcre2'
- 'systemd-libs')
-makedepends=('git'
- 'gobject-introspection'
- 'gtk-doc'
- 'meson'
- 'vala'
- 'gperf')
-options=('!emptydirs')
+license=(LGPL)
+depends=(fribidi
+ gnutls
+ gtk3
+ pcre2
+ systemd-libs)
+makedepends=(git
+ gobject-introspection
+ gtk-doc
+ meson
+ vala
+ gperf)
+options=(!emptydirs)
# Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='https://src.fedoraproject.org/rpms/vte291'
@@ -70,22 +70,22 @@ _pick() {
}
package_vte3-notification(){
- depends+=('vte-notification-common')
- provides=("vte3=${pkgver}")
- conflicts=('vte3')
+ depends+=(vte-notification-common)
+ provides=(vte3=${pkgver} libvte-2.91.so)
+ conflicts=(vte3)
- DESTDIR="${pkgdir}" meson install -C build
+ meson install -C build --destdir "$pkgdir"
_pick vte-common "$pkgdir"/etc/profile.d
_pick vte-common "$pkgdir"/usr/lib/{systemd,vte-urlencode-cwd}
}
package_vte-notification-common() {
- depends=('sh')
+ depends=(sh)
pkgdesc='Common files used by vte and vte3'
- arch=('any')
- provides=("vte-common=${pkgver}")
- conflicts=('vte-common')
+ arch=(any)
+ provides=(vte-common=${pkgver})
+ conflicts=(vte-common)
mv vte-common/* "$pkgdir"
}