summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Edson2021-02-18 19:34:19 -0800
committerJason Edson2021-02-18 19:34:27 -0800
commit70545aa4d4b6bf9b2808add83b7553af53bdbce4 (patch)
treeb76982c5480cb64ab4e7a51d072f755036284a3f
parenta81ddb2e01fb1abf83eec9690cd6b682f2fd3957 (diff)
downloadaur-70545aa4d4b6bf9b2808add83b7553af53bdbce4.tar.gz
Update and add new patches for 0.62.3
Also update branch to f34
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6da590dd06e2..cb614ae1e324 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
- pkgver = 0.62.2
- pkgrel = 2
+ pkgver = 0.62.3
+ pkgrel = 1
url = https://wiki.gnome.org/Apps/Terminal/VTE
arch = i686
arch = x86_64
@@ -19,17 +19,21 @@ pkgbase = vte3-notification
depends = pcre2
depends = gnutls
options = !emptydirs
- source = git+https://git.gnome.org/browse/vte#tag=0.62.2
- source = vte291-cntnr-precmd-preexec-scroll.patch-f4d77c06d3f39a93270cbfb65a24d0470b2f48b0::https://src.fedoraproject.org/rpms/vte291/raw/f4d77c06d3f39a93270cbfb65a24d0470b2f48b0/f/vte291-cntnr-precmd-preexec-scroll.patch
+ source = git+https://git.gnome.org/browse/vte#tag=0.62.3
+ source = vte291-cntnr-precmd-preexec-scroll.patch-03ce959c3bbba97cd9a0c50fa0d6037d695eaf74::https://src.fedoraproject.org/rpms/vte291/raw/03ce959c3bbba97cd9a0c50fa0d6037d695eaf74/f/vte291-cntnr-precmd-preexec-scroll.patch
+ source = vte291-gcc11.patch-03ce959c3bbba97cd9a0c50fa0d6037d695eaf74::https://src.fedoraproject.org/rpms/vte291/raw/03ce959c3bbba97cd9a0c50fa0d6037d695eaf74/f/vte291-gcc11.patch
+ source = 0001-Revert-widget-Limit-select-all-to-the-writable-regio.patch-03ce959c3bbba97cd9a0c50fa0d6037d695eaf74::https://src.fedoraproject.org/rpms/vte291/raw/03ce959c3bbba97cd9a0c50fa0d6037d695eaf74/f/0001-Revert-widget-Limit-select-all-to-the-writable-regio.patch
sha256sums = SKIP
sha256sums = 46cdbbf67dcd41c1a4d3c93c50c08ce2f0f58d0fa10d3247bc18a1015c21c1ea
+ sha256sums = 7615f23c0fdf723c3ad5545b11c4e532d392c8ff1034468e33e85dd66a1d9fd3
+ sha256sums = 25dee260b62c310ca00f8ac94b27c86c3d1bcf9dc697ec47e2515079e7ee1310
pkgname = vte3-notification
depends = gtk3
depends = pcre2
depends = gnutls
depends = vte-notification-common
- provides = vte3=0.62.2
+ provides = vte3=0.62.3
conflicts = vte3
pkgname = vte-notification-common
diff --git a/PKGBUILD b/PKGBUILD
index e61bc71506ee..f741a03c4fc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgbase='vte3-notification'
pkgname=("${pkgbase}" 'vte-notification-common')
-pkgver=0.62.2
-pkgrel=2
+pkgver=0.62.3
+pkgrel=1
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
arch=('i686' 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal/VTE'
@@ -18,24 +18,32 @@ options=('!emptydirs')
# Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='https://src.fedoraproject.org/rpms/vte291'
-_frepobranch='f33'
-_fpatchfile='vte291-cntnr-precmd-preexec-scroll.patch'
-_fcommit='f4d77c06d3f39a93270cbfb65a24d0470b2f48b0'
+_frepobranch='f34'
+_fpatchfile100='vte291-cntnr-precmd-preexec-scroll.patch'
+_fpatchfile101='vte291-gcc11.patch'
+_fpatchfile000='0001-Revert-widget-Limit-select-all-to-the-writable-regio.patch'
+_fcommit='03ce959c3bbba97cd9a0c50fa0d6037d695eaf74'
# VTE source ref
_vtetag=${pkgver}
source=(
"git+https://git.gnome.org/browse/vte#tag=$_vtetag"
- "${_fpatchfile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile}"
+ "${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
+ "${_fpatchfile101}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile101}"
+ "${_fpatchfile000}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile000}"
)
sha256sums=('SKIP'
- '46cdbbf67dcd41c1a4d3c93c50c08ce2f0f58d0fa10d3247bc18a1015c21c1ea')
+ '46cdbbf67dcd41c1a4d3c93c50c08ce2f0f58d0fa10d3247bc18a1015c21c1ea'
+ '7615f23c0fdf723c3ad5545b11c4e532d392c8ff1034468e33e85dd66a1d9fd3'
+ '25dee260b62c310ca00f8ac94b27c86c3d1bcf9dc697ec47e2515079e7ee1310')
prepare () {
cd "vte"
- patch -p1 -i "../${_fpatchfile}-${_fcommit}"
+ patch -p1 -i "../${_fpatchfile000}-${_fcommit}"
+ patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
+ patch -p1 -i "../${_fpatchfile101}-${_fcommit}"
}
build() {