summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBer Zoidberg2021-08-17 18:36:36 -0700
committerBer Zoidberg2021-08-17 18:36:36 -0700
commit626dadce5b50ced75e993a89e115ab0c1b7aac93 (patch)
tree8fad3ac77648e12aba5f63f77ed086d0423787f6
downloadaur-626dadce5b50ced75e993a89e115ab0c1b7aac93.tar.gz
initial pkgbuild for wlr-gammar-service-git
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c98e86d98523
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wlr-gamma-service-git
+ pkgdesc = Adjust the brightness and color temperature of wlroots-based compositors such as sway.
+ pkgver = r9.d1654d1
+ pkgrel = 1
+ url = https://github.com/berzoidberg/wlr-gamma-service
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glib2
+ depends = wayland
+ depends = wlroots
+ source = wlr-gamma-service-git::git+https://github.com/berzoidberg/wlr-gamma-service.git
+ md5sums = SKIP
+
+pkgname = wlr-gamma-service-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45899a43be0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ber Zoidberg <{firstname}.{lastname}@gmail.com>
+
+pkgname=wlr-gamma-service-git
+pkgver=r9.d1654d1
+pkgrel=1
+pkgdesc='Adjust the brightness and color temperature of wlroots-based compositors such as sway.'
+arch=('x86_64')
+license=('MIT')
+url='https://github.com/berzoidberg/wlr-gamma-service'
+depends=('glib2' 'wayland' 'wlroots')
+makedepends=('git')
+source=("$pkgname"::"git+https://github.com/berzoidberg/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make INSTALL_PATH="$pkgdir/usr" install
+ install -Dm644 res/wlr-gamma-service.service "$pkgdir/usr/lib/systemd/user/wlr-gamma-service.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}