summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang-Huang Bao2021-08-29 23:51:09 +0800
committerHuang-Huang Bao2021-08-29 23:51:27 +0800
commit429ff5f4c6ea610d5f86c422844e71f2b89761ec (patch)
tree043f7f05196e1c1ef723ec229d51e69aa699cf02
parent9648479f9e29a1fd2ecfe6cc7a9791350d658269 (diff)
downloadaur-429ff5f4c6ea610d5f86c422844e71f2b89761ec.tar.gz
fontconfig changes & patching font binary here using xdelta3 instead of fetching pre-patched font
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD47
-rw-r--r--wqy-microhei.install21
-rw-r--r--wqy-microhei.ttc.xd3bin0 -> 1896 bytes
5 files changed, 35 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08b5ad1e3aec..2aabea9b22de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = wqy-microhei-kr-patched
- pkgdesc = A Sans-Serif style high quality CJK outline font.Fix incorrect advanceWidths in hmtx for composite glyphs, which had caused Korean Hangul glyphs to stack on top of each other.
+ pkgdesc = A Sans-Serif style high quality CJK outline font
pkgver = 0.2.0_beta
- pkgrel = 2
- url = https://packages.debian.org/jessie/all/fonts-wqy-microhei
- install = wqy-microhei.install
+ pkgrel = 3
+ url = https://wenq.org
arch = any
license = GPL3
license = APACHE
license = custom:"font embedding exception"
- depends = fontconfig
- depends = xorg-font-utils
+ makedepends = xdelta3
provides = wqy-microhei
conflicts = wqy-microhei
+ source = https://downloads.sourceforge.net/project/wqy/wqy-microhei/0.2.0-beta/wqy-microhei-0.2.0-beta.tar.gz
source = 44-wqy-microhei.conf
- source = http://ftp.cn.debian.org/debian/pool/main/f/fonts-wqy-microhei/fonts-wqy-microhei_0.2.0-beta-2_all.deb
- md5sums = 2614129902fda4e45aa7f0f7b635cc4f
- md5sums = 922fc2e9b9efeaf50ad464cb1d7e57d0
+ source = wqy-microhei.ttc.xd3
+ sha512sums = c1e09c83f6427f637b3c93c7f89e427bde7fb22cedcfbb806fb036f13a553551f28d985516c7ab4c2602b4159502de36b52e6cc9b41c9b6d6e36778a6de74037
+ sha512sums = e443a5289b24ab1c405b3f1b5548f18bf1a63c54796e2e072c996680326de333ce2fb8d97aa41dbd5ac2cab99af1105e6c1a0f19313f832aa43ec4d6939f8b9e
+ sha512sums = e18bbbb98e80c231dc6a4211b57b44f5025de17887e7e09efad0f5125c0b93ca5c6098c2064d65087b0c901b0563b06258c87f801c4348422eb6c738e55ddbd9
pkgname = wqy-microhei-kr-patched
-
diff --git a/.gitignore b/.gitignore
index bebecfccbede..fca0c09818a1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
*
-!44-wqy-microhei.conf
!PKGBUILD
-!wqy-microhei.install
-!.SRCINFO \ No newline at end of file
+!.SRCINFO
+!44-wqy-microhei.conf
+!wqy-microhei.ttc.xd3
diff --git a/PKGBUILD b/PKGBUILD
index 0383c96fc4da..446793b69a23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
-# Maintainer: wicast <wicastchen at hotmail>
-# This is the patched version of wqy-microhei .ttc to fix korean rendering problem on Chromium/Chorme(and possibly other programs).
-# The patch is provided by Ben Wagner (Bungeman) who comes from Chromium team.
-# Debian's fonts-wqy-microhei package has already contained the patched version.
+# Maintainer: Huang-Huang Bao <eh5@sokka.cn>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Philacorns <opuspace@gmail.com>
-pkgname=wqy-microhei-kr-patched
_pkgname=wqy-microhei
+pkgname=$_pkgname-kr-patched
pkgver=0.2.0_beta
-pkgrel=2
-pkgdesc="A Sans-Serif style high quality CJK outline font.Fix incorrect advanceWidths in hmtx for composite glyphs, which
- had caused Korean Hangul glyphs to stack on top of each other."
+pkgrel=3
+pkgdesc="A Sans-Serif style high quality CJK outline font"
arch=('any')
license=('GPL3' 'APACHE' 'custom:"font embedding exception"')
-install=wqy-microhei.install
-url="https://packages.debian.org/jessie/all/fonts-wqy-microhei"
-depends=('fontconfig' 'xorg-font-utils')
+url="https://wenq.org"
+makedepends=('xdelta3')
provides=('wqy-microhei')
conflicts=('wqy-microhei')
-source=(
+source=("https://downloads.sourceforge.net/project/wqy/$_pkgname/${pkgver//_/-}/$_pkgname-${pkgver//_/-}.tar.gz"
'44-wqy-microhei.conf'
- "http://ftp.cn.debian.org/debian/pool/main/f/fonts-wqy-microhei/fonts-wqy-microhei_${pkgver//_/-}-${pkgrel}_all.deb"
-)
-md5sums=('2614129902fda4e45aa7f0f7b635cc4f'
- '922fc2e9b9efeaf50ad464cb1d7e57d0')
+ # https://salsa.debian.org/fonts-team/fonts-wqy-microhei/-/blob/master/wqy-microhei.ttc
+ 'wqy-microhei.ttc.xd3')
+sha512sums=('c1e09c83f6427f637b3c93c7f89e427bde7fb22cedcfbb806fb036f13a553551f28d985516c7ab4c2602b4159502de36b52e6cc9b41c9b6d6e36778a6de74037'
+ 'e443a5289b24ab1c405b3f1b5548f18bf1a63c54796e2e072c996680326de333ce2fb8d97aa41dbd5ac2cab99af1105e6c1a0f19313f832aa43ec4d6939f8b9e'
+ 'e18bbbb98e80c231dc6a4211b57b44f5025de17887e7e09efad0f5125c0b93ca5c6098c2064d65087b0c901b0563b06258c87f801c4348422eb6c738e55ddbd9')
+
build() {
- msg2 "Extracting the data.tar.xz"
- tar -xf data.tar.xz -C "$srcdir/"
+ cd $_pkgname
+ tail README.txt --lines=16 | head --lines=-3 >|FONTEXCEPTION
+ xdelta3 -df -s wqy-microhei.ttc "$srcdir"/wqy-microhei.ttc.xd3 "$srcdir"/wqy-microhei.patched.ttc
}
package() {
- install -d "$pkgdir/etc/fonts/conf.d/"
- install -Dm644 "$srcdir/44-wqy-microhei.conf" "$pkgdir/etc/fonts/conf.avail/44-wqy-microhei.conf"
- install -Dm644 "$srcdir/usr/share/fonts/truetype/wqy/wqy-microhei.ttc" "$pkgdir/usr/share/fonts/wenquanyi/${_pkgname}/wqy-microhei.ttc"
- install -Dm644 "$srcdir/usr/share/doc/fonts-wqy-microhei/copyright" "$pkgdir/usr/share/licenses/${_pkgname}/copyright"
- cd "$pkgdir/etc/fonts/conf.d/"
- ln -s ../conf.avail/44-wqy-microhei.conf .
+ install -d "$pkgdir"/usr/share/fontconfig/conf.default
+ install -Dm644 "$srcdir"/44-wqy-microhei.conf "$pkgdir"/usr/share/fontconfig/conf.avail/44-wqy-microhei.conf
+ install -Dm644 "$srcdir"/wqy-microhei.patched.ttc "$pkgdir"/usr/share/fonts/wenquanyi/$_pkgname/wqy-microhei.ttc
+ install -Dm644 "$srcdir"/$_pkgname/FONTEXCEPTION "$pkgdir"/usr/share/licenses/$_pkgname/FONTEXCEPTION
+ ln -s ../conf.avail/44-wqy-microhei.conf "$pkgdir"/usr/share/fontconfig/conf.default/44-wqy-microhei.conf
}
diff --git a/wqy-microhei.install b/wqy-microhei.install
deleted file mode 100644
index 2b62c15784b8..000000000000
--- a/wqy-microhei.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_install() {
- echo -n "Updating font cache... "
- mkfontscale /usr/share/fonts/wenquanyi/wqy-microhei
- mkfontdir /usr/share/fonts/wenquanyi/wqy-microhei
- fc-cache -s /usr/share/fonts/wenquanyi/wqy-microhei
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- rm -r /usr/share/fonts/wenquanyi/wqy-microhei
- rmdir --ignore-fail-on-non-empty /usr/share/fonts/wenquanyi/
-}
-
-op=$1
-shift
-
-$op $*
diff --git a/wqy-microhei.ttc.xd3 b/wqy-microhei.ttc.xd3
new file mode 100644
index 000000000000..a78d8cc4bfec
--- /dev/null
+++ b/wqy-microhei.ttc.xd3
Binary files differ