summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2017-07-05 13:02:30 -0400
committerEli Schwartz2017-07-05 13:02:30 -0400
commit9c2fa66403834b43e845d42d6f34bb4db9594c43 (patch)
tree834121d884f969d857c54ca5abf29d2e7ef2003d /PKGBUILD
parent9315e46c66ff50e16883a477e118ed1c64614881 (diff)
downloadaur-9c2fa66403834b43e845d42d6f34bb4db9594c43.tar.gz
upgpkg: calibre-git 3.2.1.r51.ga060fae673-1
We can now build manpages from the sphinx documentation, so do that. Also fix build error caused by commented-out `translations` command. I am not even sure how on earth this got committed. But it's stupid. Bad Eli!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2912696bb82c..024b08fc4a08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=calibre-git
-pkgver=3.0.0.r30.g1829e698f5
+pkgver=3.2.1.r51.ga060fae673
pkgrel=1
_mathjax_commit=c493143c02f5809b1112af6c5a2c8eab31050118
pkgdesc="Ebook management application, from git"
@@ -22,7 +22,7 @@ depends=('chmlib' 'icu' 'libmtp' 'libusbx' 'libwmf' 'mtdev' 'optipng' 'podofo'
'python2-dukpy' 'python2-lxml' 'python2-mechanize' 'python2-msgpack'
'python2-netifaces' 'python2-unrardll' 'python2-pillow' 'python2-psutil'
'python2-pygments' 'python2-pyqt5' 'python2-regex' 'qt5-svg' 'qt5-webkit')
-makedepends=('git' 'qt5-x11extras' 'xdg-utils' 'rapydscript-ng')
+makedepends=('git' 'qt5-x11extras' 'xdg-utils' 'rapydscript-ng' 'python2-sphinx')
optdepends=('ipython2: to use calibre-debug')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -67,9 +67,10 @@ build() {
LANG='en_US.UTF-8' python2 setup.py build
LANG='en_US.UTF-8' python2 setup.py iso639
LANG='en_US.UTF-8' python2 setup.py iso3166
-# LANG='en_US.UTF-8' python2 setup.py translations
+ LANG='en_US.UTF-8' python2 setup.py translations
LANG='en_US.UTF-8' python2 setup.py gui
LANG='en_US.UTF-8' python2 setup.py resources
+ LANG='en_US.UTF-8' python2 setup.py man_pages
# This tries to download new user-agent data, so pre-seed a
# recently-generated copy to allow offline builds.
cp ../user-agent-data.json resources/
@@ -88,6 +89,8 @@ package() {
XDG_DATA_DIRS="${pkgdir}/usr/share" LANG='en_US.UTF-8' python2 setup.py install \
--staging-root="${pkgdir}/usr" --prefix=/usr
+ cp -a man-pages/ "${pkgdir}/usr/share/man"
+
install -Dm644 resources/calibre-mimetypes.xml "${pkgdir}/usr/share/mime/packages/calibre-mimetypes.xml"
sed -i '/^numeric_version = /c\numeric_version = '"$(printf "(%s, %s, %s, '%s', '%s')" ${pkgver//./ })" \