summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112019-02-01 21:53:34 +0100
committerjose17112019-02-01 21:53:34 +0100
commitf751267cdce743b28defddf5548064ae9927dbb5 (patch)
treead77df142ee0ae8e84343353f13282472635e032 /PKGBUILD
parent6c3343cec22b953bbdfb076c69ac69bb82df35d3 (diff)
downloadaur-f751267cdce743b28defddf5548064ae9927dbb5.tar.gz
Update deps + debug mode off (thanks @J!PRA)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8936da1eb7db..88edf8a15ef5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Jose Riha <jose 1711 gmail com>
# Contributor: Dominika Solarz <dominikasolarz@gmail.com>
+# Contributor: J!PRA
+
pkgname=openlierox
pkgver=0.58_rc5
-pkgrel=1
+pkgrel=2
pkgdesc="An extremely addictive realtime worms shoot-em-up backed by an active gamers community"
arch=(i686 x86_64)
license=("GPL")
url="http://openlierox.sourceforge.net/"
-depends=("sdl" "sdl_mixer" "sdl_image" "hawknl" "gd" "zlib" "libxml2")
+depends=("sdl" "sdl_mixer" "sdl_image" "hawknl" "gd" "zlib" "libxml2" "libzip")
makedepends=("gendesk" "cmake")
source=("http://downloads.sourceforge.net/sourceforge/openlierox/OpenLieroX_${pkgver}.src.tar.bz2"
"options.cfg"
@@ -29,7 +31,9 @@ build() {
fi
mkdir bd && cd bd
- cmake -DSYSTEM_DATA_DIR=/usr/share ..
+ cmake -DSYSTEM_DATA_DIR=/usr/share \
+ -DDEBUG=OFF \
+ ..
make
}