summarylogtreecommitdiffstats
path: root/0002-Makefile-general-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-Makefile-general-fixes.patch')
-rw-r--r--0002-Makefile-general-fixes.patch96
1 files changed, 49 insertions, 47 deletions
diff --git a/0002-Makefile-general-fixes.patch b/0002-Makefile-general-fixes.patch
index d4c8794ca676..d2e3236c074e 100644
--- a/0002-Makefile-general-fixes.patch
+++ b/0002-Makefile-general-fixes.patch
@@ -1,47 +1,48 @@
-From d31cbe5a360edb065defbd5545e9bcf3c12d6d1c Mon Sep 17 00:00:00 2001
+From 4916c2a75905dfd628672e13e0913e1c2515637c Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx@intelfx.name>
-Date: Sun, 23 Oct 2016 00:56:42 +0300
-Subject: [PATCH 2/6] Makefile: general fixes
+Date: Sun, 23 Oct 2016 10:21:54 +0300
+Subject: [PATCH 2/5] Makefile: general fixes
---
- Makefile | 62 ++++++++++++++++++++++++--------------------------------------
- 1 file changed, 24 insertions(+), 38 deletions(-)
+ Makefile | 57 +++++++++++++++++++++++++++++----------------------------
+ 1 file changed, 29 insertions(+), 28 deletions(-)
diff --git a/Makefile b/Makefile
-index 387b221..4c83e4e 100644
+index 387b221..6b707a9 100644
--- a/Makefile
+++ b/Makefile
-@@ -382,7 +382,7 @@ JBGOPTS=-m 16 -d 0 -p 92 # Equivalent options for pbmtojbg
+@@ -42,7 +42,7 @@ FOODB=$(PREFIX)/share/foomatic/db/source
+
+ # User ID's
+ LPuid=-oroot
+-LPgid=-glp
++LPgid=-groot
+ ifeq ($(UNAME),Darwin)
+ LPuid=-oroot
+ LPgid=-gwheel
+@@ -381,8 +381,8 @@ JBGOPTS=-m 16 -d 0 -p 92 # Equivalent options for pbmtojbg
+ #
# The usual build rules
#
- all: all-test $(PROGS) $(BINPROGS) $(SHELLS) getweb \
+-all: all-test $(PROGS) $(BINPROGS) $(SHELLS) getweb \
- all-icc2ps all-osx-hotplug man doc \
++all: $(PROGS) $(BINPROGS) $(SHELLS) getweb \
+ all-icc2ps man doc \
all-done
all-test:
-@@ -554,11 +554,6 @@ getweb: getweb.in Makefile
- all-icc2ps:
- cd icc2ps; $(MAKE) all
-
--all-osx-hotplug:
--ifeq ($(UNAME),Darwin)
-- cd osx-hotplug; $(MAKE) all
--endif
--
- ok: ok.o $(LIBJBG)
- $(CC) $(CFLAGS) ok.o $(LIBJBG) -o $@
-
-@@ -645,8 +640,6 @@ install-test:
- #
-
-
--UDEVBIN=$(DESTDIR)/bin/
--
- install-prog:
+@@ -604,8 +604,8 @@ command2foo2lava-pjl.o: command2foo2lava-pjl.c
+ #
+ # Installation rules
+ #
+-install: all install-test install-prog install-icc2ps install-osx-hotplug \
+- install-extra install-crd install-foo install-ppd \
++install: all install-prog install-icc2ps install-osx-hotplug \
++ install-extra install-crd install-ppd \
+ install-gui install-desktop install-filter \
+ install-man install-doc
#
- # Install driver, wrapper, and development tools
-@@ -654,8 +647,8 @@ install-prog:
+@@ -654,8 +654,8 @@ install-prog:
$(INSTALL) -d $(BIN)
$(INSTALL) -c $(PROGS) $(SHELLS) $(BIN)/
if [ "$(BINPROGS)" != "" ]; then \
@@ -52,7 +53,7 @@ index 387b221..4c83e4e 100644
fi
#
# Install gamma correction files. These are just templates,
-@@ -735,7 +728,7 @@ install-crd:
+@@ -735,7 +735,7 @@ install-crd:
# Install prebuilt CRD files (from m2300w project)
#
$(INSTALL) -d $(SHAREZJS)/
@@ -61,7 +62,7 @@ index 387b221..4c83e4e 100644
for i in crd/zjs/*.*; do \
$(INSTALL) -c -m 644 $$i $(SHAREZJS)/crd/; \
done
-@@ -743,7 +736,7 @@ install-crd:
+@@ -743,7 +743,7 @@ install-crd:
# Install prebuilt CRD files for CLP-300/CLP-600
#
$(INSTALL) -d $(SHAREQPDL)/
@@ -70,7 +71,7 @@ index 387b221..4c83e4e 100644
for i in crd/qpdl/*cms* crd/qpdl/*.ps; do \
$(INSTALL) -c -m 644 $$i $(SHAREQPDL)/crd/; \
done
-@@ -753,7 +746,7 @@ install-psfiles:
+@@ -753,7 +753,7 @@ install-psfiles:
# Install prebuilt psfiles files (from m2300w project)
#
$(INSTALL) -d $(SHAREHP)/
@@ -79,7 +80,7 @@ index 387b221..4c83e4e 100644
for i in psfiles/*.*; do \
$(INSTALL) -c -m 644 $$i $(SHAREHP)/psfiles/; \
done
-@@ -767,14 +760,14 @@ install-extra:
+@@ -767,14 +767,14 @@ install-extra:
#
$(INSTALL) -d $(SHAREZJS)/
# foo2zjs ICM files (if any)
@@ -96,7 +97,7 @@ index 387b221..4c83e4e 100644
for i in sihp1*.img; do \
if [ -f $$i ]; then \
base=`basename $$i .img`; \
-@@ -783,7 +776,7 @@ install-extra:
+@@ -783,7 +783,7 @@ install-extra:
fi; \
done
# foo2xqx Firmware files (if any)
@@ -105,7 +106,7 @@ index 387b221..4c83e4e 100644
for i in sihpP*.img; do \
if [ -f $$i ]; then \
base=`basename $$i .img`; \
-@@ -792,49 +785,49 @@ install-extra:
+@@ -792,49 +792,49 @@ install-extra:
fi; \
done
# foo2oak ICM files (if any)
@@ -162,7 +163,7 @@ index 387b221..4c83e4e 100644
for i in hbpl*.icm; do \
if [ -f $$i ]; then \
$(INSTALL) -c -m 644 $$i $(SHAREHBPL)/icm/; \
-@@ -851,30 +844,22 @@ install-ppd:
+@@ -851,14 +851,14 @@ install-ppd:
# Install PPD files for CUPS
#
export PATH=$$PATH:`pwd`:; \
@@ -179,15 +180,7 @@ index 387b221..4c83e4e 100644
done; \
ppdmgr -u; \
elif [ -d $(PPD) ]; then \
-- find $(PPD) -name '*foo2zjs*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2hp*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2xqx*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2lava*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2qpdl*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2slx*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2hiperc*' | xargs rm -rf; \
-- find $(PPD) -name '*foo2hbpl*' | xargs rm -rf; \
- [ -d $(PPD)/foo2zjs ] || mkdir $(PPD)/foo2zjs; \
+@@ -874,7 +874,7 @@ install-ppd:
cd PPD; \
for ppd in *.ppd; do \
modify-ppd <$$ppd | gzip > $(PPD)/foo2zjs/$$ppd.gz; \
@@ -196,7 +189,7 @@ index 387b221..4c83e4e 100644
done; \
fi
#
-@@ -884,21 +869,21 @@ install-ppd:
+@@ -884,21 +884,21 @@ install-ppd:
cd PPD; \
for ppd in *.ppd; do \
modify-ppd <$$ppd | gzip > $(MODEL)/$$ppd.gz; \
@@ -221,7 +214,16 @@ index 387b221..4c83e4e 100644
done; \
fi
-@@ -1040,7 +1025,8 @@ install-hotplug-osx:
+@@ -939,7 +939,7 @@ DEVDDIR=/etc/devd
+ ifeq ($(UNAME),Darwin)
+ install-hotplug: install-hotplug-test install-hotplug-osx
+ else
+-install-hotplug: install-hotplug-test install-hotplug-prog
++install-hotplug: install-hotplug-prog
+ endif
+
+ install-hotplug-test:
+@@ -1040,7 +1040,8 @@ install-hotplug-osx:
install-filter:
if [ "$(CUPS_SERVERBIN)" != "" ]; then \