summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 19 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c63180c912b..bd2ba06d5974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,30 @@
-# Maintainer: Daniel Sandman <revoltism@gmail.com>
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=systemd-manager-git
-pkgver=0.4.5.r18.g5bf1bdc
+pkgname=systemd-manager
+pkgver=0.4.5
pkgrel=1
pkgdesc="A program written with Rust that allows the user to manage their systemd services via a GTK3 GUI."
arch=('i686' 'x86_64')
-url="https://github.com/mmstick/systemd-manager/"
-license=('GPL2')
+url="https://github.com/mmstick/systemd-manager"
+license=('GPL3')
depends=('gtk3')
-makedepends=('cargo' 'git')
-provides=('systemd-manager')
-conflicts=('systemd-manager')
-source=("$pkgname::git+https://github.com/mmstick/systemd-manager/#branch=master")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
+makedepends=('cargo')
+conflicts=('systemd-manager-git')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('7358fce5be146d43f2908b582c96ae2da9a20f17cd5e760f486bbda4e4af77f4')
build() {
- cd "$pkgname"
- cargo build --release
+ cd "$pkgname-$pkgver"
+ cargo build --release
}
package() {
- cd "$pkgname"
- install -D -m755 target/release/systemd-manager "$pkgdir/usr/bin/systemd-manager"
- install -D -m755 assets/systemd-manager-pkexec "$pkgdir/usr/bin/systemd-manager-pkexec"
- install -D -m644 assets/systemd-manager.desktop "$pkgdir/usr/share/applications/systemd-manager.desktop"
- install -D -m644 assets/org.freedesktop.policykit.systemd-manager.policy "$pkgdir/usr/share/polkit-1/actions/org.freedesktop.policykit.systemd-manager.policy"
- install -D -m644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd "$pkgname-$pkgver"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/polkit-1/actions"
+ install -m 755 target/release/systemd-manager "$pkgdir/usr/bin"
+ install -m 755 assets/systemd-manager-pkexec "$pkgdir/usr/bin"
+ install -m 644 assets/systemd-manager.desktop "$pkgdir/usr/share/applications"
+ install -m 644 assets/org.freedesktop.policykit.systemd-manager.policy "$pkgdir/usr/share/polkit-1/actions"
}