summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenwoodFox2022-01-29 12:05:47 -0500
committerKenwoodFox2022-01-29 12:05:47 -0500
commitf5c256c738f85f0e34ee8235b6aecc9022cc1d3d (patch)
tree11c62d88a08695363651b215ae7e5aef46b73ccb
downloadaur-f5c256c738f85f0e34ee8235b6aecc9022cc1d3d.tar.gz
Import axon launcher
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD25
-rw-r--r--axon-launcher.install25
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..885f963c6e5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = axon-launcher
+ pkgdesc = Axon, a WPILib tool
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://docs.wpilib.org/en/stable/docs/software/wpilib-tools/axon/introduction.html
+ install = axon-launcher.install
+ arch = x86_64
+ groups =
+ license = WPIlib
+ depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = expat
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = libcups
+ depends = libdrm
+ depends = libnotify
+ depends = libsecret
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxss
+ depends = libxtst
+ depends = mesa
+ depends = nspr
+ depends = nss
+ depends = pango
+ depends = tuxedo-control-center
+ depends = util-linux-libs
+ depends = xdg-utils
+ depends = docker
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/wpilibsuite/Axon/releases/download/v0.1.0/launcher_0.1.0_amd64.deb
+ sha512sums_x86_64 = f97a28a190ea81e778107c96fdb4001ed9df7e4a5a30091b917ef02d4daa699ccf1c4c0ad395ddd0a547bd0e887068d448c08c9e4bf6e39aecb95b5e466af4e6
+
+pkgname = axon-launcher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8e07c8d741
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Generated by debtap
+# Maintainer: FRC1721
+# Contributor: FRC1721
+pkgname=axon-launcher
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Axon, a WPILib tool"
+arch=('x86_64')
+url="https://docs.wpilib.org/en/stable/docs/software/wpilib-tools/axon/introduction.html"
+license=('WPIlib')
+groups=('')
+depends=('alsa-lib' 'atk' 'at-spi2-atk' 'at-spi2-core' 'cairo' 'dbus' 'desktop-file-utils' 'expat' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libcups' 'libdrm' 'libnotify' 'libsecret' 'libx11' 'libxcb' 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxkbcommon' 'libxrandr' 'libxss' 'libxtst' 'mesa' 'nspr' 'nss' 'pango' 'tuxedo-control-center' 'util-linux-libs' 'xdg-utils' 'docker')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/wpilibsuite/Axon/releases/download/v0.1.0/launcher_0.1.0_amd64.deb")
+sha512sums_x86_64=('f97a28a190ea81e778107c96fdb4001ed9df7e4a5a30091b917ef02d4daa699ccf1c4c0ad395ddd0a547bd0e887068d448c08c9e4bf6e39aecb95b5e466af4e6')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "/opt/Axon/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/axon-launcher.install b/axon-launcher.install
new file mode 100644
index 000000000000..37d1bf93b999
--- /dev/null
+++ b/axon-launcher.install
@@ -0,0 +1,25 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Axon/launcher' '/usr/bin/axonLauncher'
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/Axon/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/axonLauncher'
+ update-desktop-database -q
+}