summarylogtreecommitdiffstats
path: root/.SRCINFO
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-03 19:00:51 +0300
committerCaleb Maclennan2020-10-03 19:06:44 +0300
commit7d672b8ff80aa56fc73ee0ec99a6a314e8ea95da (patch)
tree753250a454fa34366ce81b4278a3926280d052d4 /.SRCINFO
parent038b3db810e4a825351f6ac1879f2e044a72ff17 (diff)
downloadaur-7d672b8ff80aa56fc73ee0ec99a6a314e8ea95da.tar.gz
Fix dependencies and overhaul PKGBUILD scripting
This fixes a number of oversights and (in my opinion) makes it a lot easier to maintain because of simpler scripting (more advanced use of shell function for less copied code, etc.). * Fix completely missing dependencies, both build time and run time. Build time needs all Lua targets, run time needs only matching Lua versions. * Use `luarocks` argument to avoid root manifests rather than removing them after the fact. * Do not repeat code, use re-usable functions (following Arch packaging convention for private namespace) * Don't bother with unnecessary code like testing for a file, removing it, then linking it when a force copy will do (a force link would work, but could cause problems later if we ever have to introduce patches). * Use `shellharden` to confirm and normalize shell quoting issues. Not always my favorite style but at least its consistent.
Diffstat (limited to '.SRCINFO')
-rw-r--r--.SRCINFO26
1 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 218bee22a8e4..3698c950ec55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = lua-discount
pkgdesc = Lua bindings for the Discount Markdown library
pkgver = 0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/craigbarnes/lua-discount
arch = x86_64
license = ISC
+ makedepends = lua
+ makedepends = lua53
+ makedepends = lua52
+ makedepends = lua51
makedepends = luarocks
depends = discount
source = https://github.com/craigbarnes/lua-discount/archive/0.4.tar.gz
@@ -15,14 +19,22 @@ pkgbase = lua-discount
sha256sums = 8b2fffc6b27a33bf6958a2a2293ce19ce5cbd7206ccb6dda7a9d3abe6f80c9fa
pkgname = lua-discount
- pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.4
+ pkgdesc = Lua bindings for the Discount Markdown library (for Lua 5.4)
+ depends = discount
+ depends = lua
-pkgname = lua51-discount
- pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.1
+pkgname = lua53-discount
+ pkgdesc = Lua bindings for the Discount Markdown library (for Lua 5.3)
+ depends = discount
+ depends = lua53
pkgname = lua52-discount
- pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.2
+ pkgdesc = Lua bindings for the Discount Markdown library (for Lua 5.2)
+ depends = discount
+ depends = lua52
-pkgname = lua53-discount
- pkgdesc = Lua bindings for the Discount Markdown library for Lua 5.3
+pkgname = lua51-discount
+ pkgdesc = Lua bindings for the Discount Markdown library (for Lua 5.1)
+ depends = discount
+ depends = lua51