summarylogtreecommitdiffstats
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorstefanwimmer1282022-12-22 22:22:27 +0100
committerstefanwimmer1282022-12-22 22:22:27 +0100
commitb83e0d35af97cb813d84241df1ccc14cdcf63538 (patch)
tree4658adea51e0511025e66fb7300861d39680a9a0 /.gitlab-ci.yml
parenta92c8fa7264f02168e4b91ac96c0c244baa02ac8 (diff)
downloadaur-b83e0d35af97cb813d84241df1ccc14cdcf63538.tar.gz
Rename package to firedragon-unsigned
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml4
1 files changed, 1 insertions, 3 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index fa49e15bb4e1..07f9e89ab29b 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -10,7 +10,5 @@ build:
- passwd -d builduser
- printf 'builduser ALL=(ALL) ALL\n' | tee -a /etc/sudoers
- sudo -u builduser sh -c "gpg --recv-key EBE41E90F6F12F6D && makepkg -s --noconfirm"
- artifacts:
- paths:
- - firedragon-*.pkg.tar.zst
+ - "bash -c 'source PKGBUILD && curl --header \"JOB-TOKEN: $CI_JOB_TOKEN\" --upload-file \"$pkgname-$pkgver-$pkgrel-x86_64.pkg.tar.zst\" \"$CI_API_V4_URL/projects/$CI_PROJECT_ID/packages/generic/$pkgname/$pkgver-$pkgrel/$pkgname-$pkgver-$pkgrel-x86_64.pkg.tar.zst\"'"
timeout: 2h